cuda::remap error

Hello,
My product is TX2,when I ran the program that included the cuda function on the opencv in Qtcreator.

cv::cuda::remap would appear error,

OpenCV Error: Gpu API call (invalid configuration argument) in call.

But the error was very strange,I had 300 pictures,when I ran the program,cv::cuda::remap would appear

error in second pictures,when ran program from second picture,the same error appeared in 7th picture,

the 300 pictures is similar.

Thanks!

Hi,

Could you share more information of the OpenCV setup on your TX2?

Please remember that the default OpenCV included in JetPack doesn’t build with CUDA support.
If you want to enable more OpenCV feature, here is a script can give you some information:
https://github.com/AastaNV/JEP/blob/master/script/install_opencv3.4.0.sh

Thanks.

Hello,AastaLLL

yes,I used the install_opencv3.4.0.sh,opencv has compiled with cuda,

That OpenCV Error: Gpu API call (invalid configuration argument) in call appeared cuda functions ,

such as cv::cuda::Filter appear.

I want to know where is the problem,and how to fix it.

Thank you!

Hi,

Have you tested your program on other environment?

Invalid configuration is usually caused when API changes.
Please remember that there are some API changes in different OpenCV version, especially from 2.4.13 to 3.x.
It’s recommended to check which OpenCV version required for your program first.

Thanks.