CuDNN is not enabled


If this post is not inappropriate in this category, please let me know.
I am quite new to Jetson Nano.

I am going to try Edge AI.
So, I have installed the following software packages to my Jetson Nano:

Python 3.6.9
Cuda 10.2
CuDNN 8201
cupy 7.8.0
PyTorch 1.8.0
chainer 7.8.1

Then, I ran my deep learning program on the Jetson Nano. The program had run normally
on another PC with a NVIDIA GPU board.
But I saw the following message:

“/home/fp_user/.local/lib/python3.6/site-packages/chainer/backends/ UserWarning: cuDNN is not enabled.
Please reinstall CuPy after you install cudnn
(see Installation — CuPy 11.2.0 documentation).
‘cuDNN is not enabled.\n’”

I read the page above the URL and tried the command in the page
But it only caused the following error:

“Defaulting to user installation because normal site-packages is not writeable
Looking in links: (I cannot include the URL)
ERROR: Could not find a version that satisfies the requirement cupy-cuda102 (from versions: none)
ERROR: No matching distribution found for cupy-cuda102”

I would like to solve this issue. I would appreciate your advice.

Thanks in advance,

H. Fujimoto

I’d suggest avoid using Chainer as it is no longer actively maintained to support recent platforms including Arm. However, in case you need, use Python 3.8 + CuPy 10.6 with Chainer v7.8.1.


Dear kamehashi-san,

Thank you for your advice.

I have not been able to convert my Chainer application to PyTorch one.

So, I continue using Chainer for a while. I will obey your second advice.

Thank you.

Best regards,

H. Fujimoto

Dear maehashi-san,

The name I wrote in the previous e-mail was wrong.

I am very sorry for my careless mistake.

H. Fujimoto