Custom dts(i) not taken into account

Hi All,
In Linux_for_Tegra folder, I find following :


I would like to know which of above .dtb will be used to flash into the kernel-dtb partition when I issue the following command :

sudo ./ -k kernel-dtb jetson-xavier-nx-devkit-emmc mmcblk0p1

so that I could replace it by my customized .dtb, please?

hello khang.l4es,

the quickest way is checking the flashing messages. you should see the binary file which has flashed to kernel-dtb partition.
for example,

[ 464.1538 ] Writing partition kernel-dtb with tegra194-p3668-all-p3509-0000_sigheader.dtb.encrypt
[ 464.1617 ] [................................................] 100%

the binary file used by flash script is… $OUT/Linux_for_Tegra/kernel/dtb/tegra194-p3668-all-p3509-0000.dtb
this is refer to the flash configuration file, p3668.conf.common
for example, DTB_FILE=tegra194-p3668-all-p3509-0000.dtb;.

you should also check Flash Script Usage, you may update the flash command-line by using -d options to specify the pathname of a device tree file.

Hi @JerryChang ,

Strangely that if I copy $OUT/Linux_for_Tegra/kernel/dtb/tegra194-p3668-all-p3509-0000.dtb to /boot folder on the board and add FDT /boot/tegra194-p3668-all-p3509-0000.dtb entry into /boot/extlinux/extlinux.conf then my custom dts is taken into account but it is NOT the case via kernel-dtb partition flashing command which reports successfully and FDT entry is removed.

Is it possible that the following file is not updated :


I’m using L4T R32.5.1.


hello khang.l4es,

for your reference,
here’re steps to update kernel-dtb partition.

  1. update $OUT/Linux_for_Tegra/kernel/dtb/tegra194-p3668-all-p3509-0000.dtb
  2. perform flash script, $ sudo ./ -r -k kernel-dtb jetson-xavier-nx-devkit-emmc mmcblk0p1
  3. remove FDT entry in the extlinux.conf.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.