Deactivating RTC Battery Charging

Hello,
is there a way to configure the TX2 PMIC (MAX77620) to not charge a battery connected to VDD_RTC. We connected a CR2302 battery via a 1k series resistor to the TX2 without a series diode. To avoid shortening the lifetime of the battery we would like to disable the PMIC charing feature. Is that possible?

MfG
Johannes

Please refer to this topic: Primary battery for RTC for Jetson TX2

Hi again,
Thanks to @vishruthj, he solved that Problem for me.

It looks like resetting the BBCEN ( Backup Battery Charger Enable ) Bit in the PMIC configuration file tegra186-mb1-bct-pmic-quill-p3310-1000-c XX .cfg by adding the following lines:

pmic.generic.1.block[0].count = 2 ;
pmic.generic.1.block[0].commands[0].0x00.0x40 = 0x40;
pmic.generic.1.block[0].commands[1].0x04.0x01 = 0x00;

And removing the backup-battery node under bpmp_i2c/spmic@3c/ in the linux device tree does the trick.

Bit 0 of register 4 stays reset.

nvidia@tegra-ubuntu:~$ sudo cat /sys/kernel/debug/regmap/4-003c-power-slavstersi
00: d2
01: 03
02: 00
03: df
04: 0e