Deepstream 6.3 deepstream-app cannot decode rtsp stream, output is green video?

Please provide complete information as applicable to your setup.

**• Hardware Platform: GPU
**• DeepStream Version 6.3
**• TensorRT Version 8.6.1
**• NVIDIA GPU Driver Version 535
**• Issue Type bugs

I run deepstream-app with an rtsp stream with codec:

Get the result as green video.

After debugging I realized that the main cause was decodebin.

To demonstrate that I made a command line example using gst-launch-1.0 and export GST_DEBUG=“*:6”.
Use decode bin:
gst-launch-1.0 -v rtspsrc location=rtsp://localhost:8554/videos/KG20102023_2.mkv ! decodebin ! nveglglessink > decodebin.txt
File log decodebin.txt:
decocdebin.txt (164.2 KB)
decodebin-gst.txt (54.2 MB)


Use rtph265depay, h265parse, nvv4l2decoder explicitly can decode rtsp stream:
gst-launch-1.0 -v rtspsrc location=rtsp://localhost:8554/videos/KG20102023_2.mkv ! rtph265depay ! h265parse ! nvv4l2decoder ! nveglglessink > nvv4l2decoder.txt
File log nvv4l2decoder.txt:
nvv4l2decoder.txt (137.2 KB)
nvv4l2decoder-gst.txt (53.3 MB)

As a result, using rtph265depay, h265parse, nvv4l2decoder can explicitly decode the rtsp stream.

Please explain to me why decodebin cannot decode this rtsp stream, I only get decode errors with decode bin on some specific streams not all. Or is there a way to replace decodebin in deepstream-app with another decoder?

Could you try to get the graph of the two pipelines by referring to the

I see both pipelines use nvv4l2decoder why decode bin cannot decode causing green video error?

I see the difference between pipeline1 and pipeline2 is CapsFilter, is it a problem how to decodebin not add CapsFilter

That could be the problem. We usually use uridecoderbin instead of decodebin. Could you also try the uridecodebin plugin? Thanks

I tried with uridecodebin but still can’t decode, the result is still green video

OK. You can use the rtsp source pipeline temporarily.
And could you give us the source video and describe the way you set up the rtsp server step by step?

Could you refer to this Build rtsp server to build a rtsp server and try that with our latest version: 6.4? I’ve tested it on my board and it works fine.

1 Like

On your test, did you use rtsp server live555?

No. You can use the way I attached in the previous comment to set up an rtsp server and try.

1 Like

I tried your rtsp server in the comment above and the result is that decodebin can decode. But I still want to know why live555 cannot use decodebin to decode even though the stream can still be viewed from VLC when the rtsp server is live555.

Our hardware decoder doesn’t do much compatibility. It is possible that the rtsp stream generated by live555 does not fit the caps of the plugin when using decoderbin. When you use VLC, it uses a software decoder with better compatibility.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.