Deepstream Crashed when using multil rtsp/rtmp urls Over two hours。

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU): Nx/Rtx2060
• DeepStream Version: 5.0/5.1
• TensorRT Version** 7.0/7.1
• NVIDIA GPU Driver Version (valid for GPU only): 460.84
• Issue Type( questions, new requirements, bugs): questions.
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing): just use demo,such “deepstream-app -c config demo.txt”

When I use deepstream to connect some IPC cameras such as rtsp or rtmp urls, at First is ok , but can’t keep stable more than Two hours.
And not only using "deepstream-app -c xxx.txt " but also “deestream_python_apps” or by “deepstream-test3” demo, and I found that some cameras will be stop and can’t be decoded until the all code crashed and exit unexpected.

and I set “live-source=1 in streammux and sync=0 in sink”, but did not improve.

and I use Nx/RTX2060/, deepstrem5.0/5.1, docker/native , c++/python, None of them worked.

There is no useful information in your description to know what caused the unstability and crash.

Is there has huge difference between rtsp decode and rtmp decode. and I test more than 24hours , all rtmp source-decode-bin are crashed, and all rtsp source-decode-bin are worked.

They are all gstreamer opensource plugins. rtmpsrc (
rtspsrc (
Please check the difference by yourself.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.