Deepstream-plugin make failed

trt_utils.h:82:22: error: ‘nvinfer1::DimsHW YoloTinyMaxpoolPaddingFormula::compute(nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, nvinfer1::DimsHW, const char*)’ marked ‘override’, but does not override

while compiling deepstream-plugins/sources/lib
The environment is
RTX 2080Ti
CUDA10.0.130-1
OpenCV-3.4.3
TensorRT 5.0.0-1

The plugin is from vat-nvidia

Hi, I’m running the same software environment. How did you get CUDA10 to work with Deepstream? I ran the sample deepstream-app and it just gave me the following error:

(gst-plugin-scanner:25243): GStreamer-WARNING **: 18:22:45.131: Failed to load plugin '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstnvosd.so': libcudart.so.9.2: cannot open shared object file: No such file or directory

Hi there,
Actually running trt example does not require DeepStream framework.
But to be honest, I also occurred the problem you mentioned when trying DeepStream on CUDA 10.

Thank you for your reply.

@qualia0000 The app/plugin is not verified for cuda10 and TensorRT 5. Please try running the app with cuda 9.2 and TensorRT 4.

OK. Thank you for your advice.