Desynchronization Issue with Animated Blend shapes: Eyebrow and Eyelash Animations Are Out of Sync with the Facial Animation in Maya"

“Desynchronization Issue Using Animated Blendshapes: Eyebrow and Eyelash Animations are out of sync with the Facial Animation in Maya”

Hello, I’m experiencing a problem with my head/face animation when using animated blend shapes. The animations for the eyelashes and brows are not synchronized with the facial animation. Additionally, they exhibit more deformation compared to the facial expressions. I’ve been grappling with this issue for weeks, so any ideas would be greatly appreciated. :) My project involves a basic custom Maya head mesh with distinct left and right eyes, eyebrows, and eyelashes. I’ve outlined my workflow below…

Step 1: I import my custom head mesh (Not a Metahuman or Real Illusion Mesh) from Maya to A2F.

Step 2: I create a Full Face Character Setup (Character Transfer), establish correspondences, and add the eyelashes and eyebrows as additional dynamic meshes.

Step 3: I go through the Mesh Fit and Post Wrap processes.

Step 4: In the Stage window, I select the Head result, Mesh, then choose the dynamic Eyelashes and Brows Meshes and apply the Prox UI.

Step 5: I connect Audio2Face to the gray Mark head using the “english_voice_male_p3_neutral.wav” file using all of the default settings. As a result, everything, including the face, both eyes, eyebrows, and eyelashes, moves together as expected.

Step 6: I generate Blendshapes clicking on the Preview in Stage, creating 46 NV Poses. I save those as a .usd file and import them into Maya.

Step 7: I select all 46 heads, then the rig head; I choose “deform” and add blend shape. Similarly, I do the same for the brows and lashes, selecting all 46 of them, then the corresponding mesh parts, and applying the blend shape.

Step 8: I create a group in Maya containing the head, brows, and lashes. I export this group using the Omniverse connector as a .usd Skeletal Mesh and then import it into my previous A2F scene.

Step 9: For Blendshape Conversion, I select my custom result head mesh still driven by the grey Mark as the Input Anim Mesh. Then, I select the imported blend shape group head as the blend shape mesh. I set up the blend shape solve and export the JSON for the face at 30 fps. I repeat the process for the brows and eyelashes.

Step 10: In Maya, I run the import JSON script for the face, brows, and lashes. This process successfully creates animated keys for all of the blend shapes but plays out of sync.

Here is a video of the issue in Maya:

The workflow seems correct. Are you able to share a flattened version of A2F file here so we can investigate? You can create a flattened version using File -> Save Flattened As...

Can I send it to you personally? I am concerned about sending it out publicly.

Yes absolutely, please do.


Awesome, how do I send it to you personally without it going out publicly?

I’ll message you

Hi Ehsan,

I was just wondering if you successfully received my flattened file and if you had any ideas about the issues I was experiencing.

Best regards,

Shaun Johnston

Hi @shaunjohnski Sorry for the late reply. Yes I received your file and redid the setup from scratch. Then exported the blendShape weights as USD and imported back to A2F. The eyelash and eyebrows seem to match completely to the skin. Then I tested json, same thing. Just make sure fps is the same when you export/import from A2F and Maya. I’m not quite sure how to replicate this issue. But I can share my scene file with you if it helps?

Hi Eshan,

I really appreciate you getting back to me. Have you tried exporting them as a Maya animated blendshapes .usd and not just a standard geo cache usd? It that would be great if you could share the file with me.

Thank you so much again!



Sure, I’ll send the files in private chat.

For future reference, the solution was to select all meshes when generating blendShapes. And connect BlendShapeSolver to the animation node under the USDSkel manually.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.