Detectnet_v2 notebook does not find "tao" or "detectnet_v2"

Please provide the following information when requesting support.

• Hardware (RTX 3080)
• Network Type (Detectnet_v2)
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here)
• Training spec file(If have, please share here)
no training spec file yet
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)


I am in the process of retraining a ResNet 50-based network on my own database of 1000+ images. I have reached the point where I am preparing tf records from my kitti format dataset. When I run the notebook cell to convert the data, I get the following:

(I also tried running it without “tao” and it doesn’t find “detectnet_v2” either)
I can run the command in the CLI.

I have also tried some of the next cells and I am getting the same kind of error messages for them too, e.g:
/bin/sh: 1: wget: not found

Do you have any idea why the notebook can’t find them?

Thank you

When you are running in the notebook, can you run "! tao info " successfully?

No, once again it fails to find the command “tao”:

It finds “cat” and “mkdir”, but not “tao”, “wget” or “ngc”.

So, you can run successfully with terminal but fail in notebook.
How did you trigger the notebook, can you share the command and log?

Hi Morganh.

I must apologise: I rebooted my machine (for a second time) and the issue now no longer occurs.
(the command used was:

Apologies for taking up your time.

Great. Glad to know the issue is gone. Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.