Display Freeze-Up Problem With nVidia 340.108 Drivers And OpenSUSE Leap 15.1 KDE Plasma 5.12.8

Hello,

I am having the following issue with my nVidia GeForce 9300M GS GPU, which is built-in to a Hewlett Packard TouchSmart, Model IQ840, Desktop PC. I have installed openSUSE Leap 15.1 Linux in the beginning of January 2020. Before this, I had openSUSE Leap 15.0 Linux installed on this system, which ran great with the nVidia GeForce 9300M GS GPU.

Issue:

Graphics Display works fine until after 5 minutes Display freezes, whole computer locks up and cannot escape out of it except for cold reboot (Power Down). The display is very clean, no garbage displayed when lock up occurs. This freeze up issue happens consistently either with compositor enabled or disabled and when no other video graphics driver is installed.

Reproducible: Always

Steps to Reproduce:

  1. sudo zypper ar -cfp 95 https://download.nvidia.com/opensuse/leap/15.1 nVidia
  2. sudo zypper ref
  3. sudo zypper install nvidia-gfxG03-kmp-default-340.108_k4.12.14_lp151.27-lp151.12.1.x86_64.rpm nvidia-uvm-gfxG03-kmp-default-340.108_k4.12.14_lp151.27-lp151.12.1.x86_64.rpm nvidia-glG03-340.108-lp151.12.1.x86_64.rpm nvidia-computeG03-340.108-lp151.12.1.x86_64.rpm
  4. Reboot the system.

Actual Results:

The system will boot up fine with nice high-resolution graphics and mouse working. Login as normal user and display works fine until after a few minutes then display will freeze completely with keyboard and mouse frozen as well. Can not exit out of it. Only cold reboot (Power Down).

Expected Results:

Graphics display should not freeze at all. The third party nVidia drivers worked fine with openSUSE Leap 15.0.

Hardware:

Hewlett Packard TouchSmart Desktop Computer
Model Number: IQ840
CPU: Intel Core 2 Duo T6400 running @ 2GHz.
Memory: 7.8 Gig of RAM
GPU: nVidia G98M [GForce 9300M GS]

Operating System:

openSUSE Leap 15.1
KDE Plasma Version 5.12.8
KDE Framework Version 5.55.0
Qt Version 5.9.7
Kernel Version 4.12.14-lp151.28.36-default
OS Type 64-bit

I have tried attaching the nvidia-bug-report.log.gz file from this run with the use of the nVidia 340.108 rpm packaged version installed. However, the NVIDIA DEVELOPER Forum web site won’t allow me to upload this file to post it.

Anyway, I was advised by a openSUSE Support person to remove the rpm packaged nVidia gfxG03-340-108 drivers and download the manual nVidia driver directly from https://nvidia.if-not-true-then-false.com. I installed this version on the openSUSE Leap 15.1 Linux but the same exact freeze up display issue occurred with this driver also. I understand that the 340.108 is the last 340.xx driver still supporting my GPU, which NVIDIA released. Anyway, I removed this 340.108 version and installed the mouveau driver temporary, which doesn’t support OpenGL > 1.0 and I need OpenGL 4.0 for a 3D CAD application that I am working on. So I downloaded the 340.107 version driver to try.

Well, I ran into a slight problem manually installing the nVidia-340-107 version driver with openSUSE Leap 15.1 kernel version 4.12.14.

  1. I made sure to uninstall the mouveau driver from the system by using the yast software package manager and removing all mouveau software packages that were installed.

  2. I even added a “blacklist mouveau” line to the /etc/modprobe.d/50-blacklist.conf file before rebooting the system.

  3. At the grub boot loader menu, I highlighted openSUSE Leap 15.1 with kernel 4.12.14 and pressed “E” for edit. Then I moved the cursor down to the line beginning with the word “linux” and pressed the “End” key to move the cursor to the end of the line and entered a space and the number 3 to enter into lever 3 mode.

  4. I press function key “F10” to proceed to boot with this kernel 4.12.14 version.

  5. I login as root in text mode and cd /usr/src/nvidia where I had the NVIDIA-Linux-x86_64-340.107.run executable file stored.

  6. I typed in sh ./NVIDIA-Linux-x86_64-340-107.run and pressed enter and it showed me the license agreement. After accepting it, then it prompted me to continue, which I did. However, it detected that the nouveau driver was still loaded in the system, which I checked by using lspci | grep VGA and it showed no driver loaded.

  7. So I tried typing: nvidia-installer -a --add-this-kernel and pressed the enter key and it started building the kernel and modules until it got to the final process as follows:

-> Error.
ERROR: Unable to build the NVIDIA kernel module interface.
ERROR: Unable to add a precompiled kernel interface for the running kernel.

Then I actually went the long route and recompiled the whole kernel-4.12.17 from scratch yesterday and it compiled fine without any errors. I rebooted the computer and went into runlevel3 mode and manually installed the nVidia 340.107 driver by executing:

sh ./NVIDIA-Linux-x86_64-340.107.run -a

and continued with the installation text screen, which ran through the installation process fine without any issue. It registered the Kernel Source Modules with DKMS and installed the 32-bit Compatibility Libraries as well as Built the Kernel Module and backup the Xorg Config file.

Attached is the NVIDIA-Installer.log file of this process to this forum posting for you to view:

nvidia-installer.log (865.0 KB)

After the nVidia driver installation process was completed, I ran:

grub2-mkconfig -o /root/grub2/grub.cfg

to insure the new kernel-4.12.17 with the nVidia driver would boot. Then I typed in:

systemctl set-default graphical.target

to insure the system would go into runlevel5 mode on boot up.

I then rebooted the system and it booted up smoothly without any issues and it went into graphical mode fantastic after I login. However, once the complete work desktop appeared on screen, the computer froze and I couldn’t exit it. The screen froze, mouse and keyboard as well. I let the system run for about ten minutes to see what happens and to generate log files. I then killed the power to the system. Lucky I have installed a second Linux system to boot up from and I used that to examine the log files from and write this report from. However, I wasn’t able to run the nvidia-bug-report.sh program to package these log files into one nvidia-bug-report.log.gz compressed file and so I uploaded each file manually to post them.

There are more log files to include but this forum is restricted to 3 links I am allowed to post in this session. I will include these additional log files at a later date. All these files are from this run current period. Maybe these log files would give you a clue to what’s going on?

I am tempted to try an earlier kernel version prior to 4.12.17 to see if it freezes. Although after testing previous versions of the nVidia driver prior to the latest 340.108, I discovered that the freeze up display problem with nVidia’s GForce 9300M GS GPU found in Hewlett Packard TouchSmart Desktop PCs and Laptops is related to the new kernel revisions prior to version 4.11.x. This display freeze up issue occurs also with Red Hat Fedora 31 using kernel version 5.6.8 within five minutes of the execution of startx when using the nVidia driver. So the issue has to do with the recent kernel revisions starting from late December 2019 on.

Thank you,

David A. Smith

The following are some of the remaining log files:

Attached is the Xorg.0.log file:

Xorg.0.log (37.9 KB)

Attached is the boot.msg file: (had to add .log suffix to allow this file to be uploadable to post.)

boot.msg.log (79.1 KB)

Attached is the messages file: (had to add .log suffix to allow this file to be uploadable to post.)

message.log (3.8 MB)

I hope these log files are helpful in tracing down the display freeze up problem.

David A. Smith

and three more remaining log files as follows:

Attached is the boot.log file:

boot.log (2.5 MB)

Attached is the boot.omsg file: (had to add .log suffix to allow this file to be uploadable to post.)

boot.omsg.log (76.4 KB)

Attached is the warn file: (had to add .log suffix to allow this file to be uploadable to post.)

warn.log (3.9 MB)

This completes all the log files for my 340.107 driver run.

David A. Smith

Unfortunately, the 340 driver is EOL, out of support since end of last year. So this could have to do with recent kernel revisions. Might be an hardware issue, too. There’s also no real hint to the reason in the logs, the kernel driver seems to crash just out of the blue.

Is there a stand alone diagnostic program available for the GeForce 9300M GS GPU iso that I can download from a web site and write to a CD or USB Flash Drive to boot up on the HP TouchSmart IQ840 to test the nVidia GPU?

Thank you,

David A. Smith

No, doesn’t exist.

Hi Guys.

I am facing with the same problem with driver No. 340.108 and Opensuse LEAP 15.2.
The laptop is HP Elitebook 8740 with a single NVIDIA Quadro FX2800M graphic card.

As malcolm said (in opensuse forum) it may work with a patch or firmware update. I was wondering whether you know where can I download the patch?

Hello everyone,

Well, since my last response concerning my issue with my HP TouchSmart IQ840 All-in-One Desktop PC, which had an NVIDIA GeForce 9300M GS graphics card installed from the factory, and freezing after about five minutes from logging into OpenSUSE Leap 15.1 Plasma Desktop environment. A few months ago, I replaced the motherboard as well as the NVIDIA GeForce 9300M GS graphics card with an NVIDIA GeForce 9600M GS graphics card, which has 512MB instead of 256MB and a little faster too. I also installed OpenSUSE Leap 15.2 and the NVIDIA 340.108 driver. Now the driver doesn’t seem to find the same DFP-0 as with the NVIDIA GeForce 9300M GS graphics card with OpenSUSE Leap 15.0 and 15.1 versions for some reason. I am using kernel version 5.3.18 with nvidia-gfxG03-kmp-default - NVIDIA graphics driver kernel module for GeForce 8xxx and newer GPUs and nvidia-uvm-gfxG03-kmp-default - NVIDIA Unified Memory kernel module packages, which seems to be working ok. However, when I run the nvidia-xconfig as root to generate the xorg.conf file, it gives me a message, which says:

which produces the following xorg.conf file:

xorg.conf.nvidia-xconfig-new (1.9 KB)

If I now reboot the system after doing this, the computer will boot up fine except when it starts up starts, I don’t have a graphics display screen appear. Instead, I get a blank screen and can’t do a ctrl+alt+f2 to switch into text mode. The following is my Xorg.0.log file from when the above event took place:

Xorg.0.log.old (5.7 KB)

One question I thought of is maybe the option in the above Xorg.conf file, the accelerator graphics mode is disabled with “AccelMethod” “none”, right? Should I change it to “AccelMethod” “xgl”? Also, why is vesa display mode used in the xorg.conf file that nvidia-xconfig generates?

If you have any ideas to try please let me know.

Thank you,

David A. Smith

I can’t access the conf-file upload and the xorg log is somehow trunceted.
I suspect nvidia-xconfig gets irritated by the dvb-t card you have. Rather use a simple xorg.conf containing only

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
  BusID "PCI:6:0:0"
EndSection

Hello!

Thank you for your reply.

I tried your suggestion of just putting the following Section block into my /etc/X11/xorg.conf file:

    Section "Device"
      Identifier "nvidia"
      Driver "nvidia"
      BusID "PCI:6:0:0"
    EndSection

However, no change in operation, same blank display with no mouse cursor. Attached is the Xorg.0.log file from this run:

Xorg.0.log (6.1 KB)

Note: towards the end of the Xorg.0.log file, always shows the following no matter what I put in the xorg.conf file as far as attempting to get the normal nvidia accelerator display to work on DFP-0 with xgl enabled:

[ 79.678] (II) NVIDIA(0): Display (Nvidia Default Flat Panel (DFP-0)) does not support
[ 79.678] (II) NVIDIA(0): NVIDIA 3D Vision stereo.
[ 79.678] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[ 79.680] (II) NVIDIA(0): NVIDIA GPU GeForce 9600M GS (G96) at PCI:6:0:0 (GPU-0)
[ 79.680] (–) NVIDIA(0): Memory: 524288 kBytes
[ 79.680] (–) NVIDIA(0): VideoBIOS: 62.94.2a.00.09
[ 79.680] (II) NVIDIA(0): Detected PCI Express Link width: 16X

First of all, why does it show the Display (Nvidia Default Flat Panel (DFP-0)) does not support NVIDIA 3D Vision stereo when it never did this with the original GeForce 9300M GS graphics card, which came installed with the HP TouchSmart IQ840 All-in-One Desktop PC? The only difference between these graphics cards is twice the video memory and a little faster GPU clock speed with the GeForce 9600M GS, right? Also, the Xorg.0.log file always seems to hang after the “Detected PCI Express Link width: 16X”. Got any clues as to why this is happening?

Now I can get “vesa mode” to work with the following /etc/X11/xorg.conf file setup:

    Section "Device"
      Identifier "modesetting"
      Driver  "modesetting"
      Option "PreferCloneMode" "true"
      Option "AccelMethod" "none"
    EndSection
    Section "Screen"
      Identifier "modesetting"
      Device "modesetting"
    EndSection

    Section "Device"
      Identifier "fbdev"
      Driver  "fbdev"
    EndSection
   Section "Screen"
      Identifier "fbdev"
      Device "fbdev"
    EndSection

    Section "Device"
      Identifier "vesa"
      Driver  "vesa"
    EndSection

    Section "Screen"
      Identifier "vesa"
      Device "vesa"
    EndSection

Section "ServerLayout"
  Identifier "Layout"
  Screen  "modesetting"
      Screen  "fbdev"
      Screen  "vesa"
    EndSection

Which the Xorg.0.log file results are as follows:

Xorg.0.log (42.4 KB)

and the display works ok except I don’t have xgl or a video mode that is compatible with smplayer or any mp4 player not to mention VariCAD.

David A. Smith

The xorg log always ending at the detection of the pcie link points towards either pcie bus or graphics card being flakey, breaking once it’s throttling up to full performance.