Does vgpu driver support vsphere 6.5 now?

I was runing esxi 6 before and installed the nvidia driver for vgpu, and it worked well.

I upgrade to esxi 6.5 and reinstall the driver for vsphere 6.5, I got this error when booting a vm:
Could not initialize plugin ‘/usr/lib64/vmware/plugin/’ for vGPU ‘grid_k220q’

[root@t7610:~] nvidia-smi
Tue Nov 22 14:35:59 2016
| NVIDIA-SMI 367.64 Driver Version: 367.64 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GRID K2 On | 0000:83:00.0 Off | Off |
| N/A 58C P8 29W / 117W | 18MiB / 4095MiB | 0% Default |
| 1 GRID K2 On | 0000:84:00.0 Off | Off |
| N/A 46C P8 28W / 117W | 18MiB / 4095MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| 0 68076 G Xorg 7MiB |
| 1 68093 G Xorg 7MiB |

[root@t7610:~] lspci -n|grep 10de
0000:03:00.0 Class 0300: 10de:0a65
0000:03:00.1 Class 0403: 10de:0be3
0000:04:00.0 Class 0300: 10de:13f1
0000:04:00.1 Class 0403: 10de:0fbb
0000:83:00.0 Class 0302: 10de:11bf [vmgfx0]
0000:84:00.0 Class 0302: 10de:11bf [vmgfx1]

Any help?

Hi Ethan

Yes ESXi 6.5 is supported, I’m also running it although my cards are Maxwell, but can confirm there are no issues.

Did you upgrade the vGPU driver in ESXi or do a clean install?

When changing the vGPU driver, I always remove the existing one, reboot, install the new one, reboot again then check SMI to make sure all is ok. Then upgrade the driver in the VM to finish off.

I’ve tried doing an upgrade with previous versions, but it usually fails so now I always go for a clean install.



I do a clean installation and install esxi driver from nvidia

So everything is fresh here, but I still experience this error. Did you see this error before?

The vib I’ve installed.
[root@t7610:~] esxcli software vib list |grep -i nvidia
NVIDIA-kepler-VMware_ESXi_6.5_Host_Driver 367.64-1OEM.650.0.0.4240417 NVIDIA VMwareAccepted 2016-11-19

I saw this article to switch gpu mode would help,-nvrm-bar1-error,-ecc

But I couldn’t find where to download this tool.

Hi Ethan

The link you’ve listed above is for newer Maxwell GPUs and is not relevant to your hardware.

That driver is correct, no issues there.

Can you check to make sure that your "Xorg service" is running on your ESXi hosts.



Hi BJones, thanks for reply, yes, it’s running

[root@t7610:~] /etc/init.d/xorg status
Xorg is running

BTW, I’m using dell cusmized esxi 6.5 version, will this cause the problem?

After reinstall the nvidia driver, now it works fine!

Yes last weeks GRID 4.1 release supports vSphere 6.5 (2016)

Release notes:

RachelBerry, thanks, I’m using this version of driver.
The release notes didn’t mention it support vsphere 6.5, but it actually did.

Hi EthanLynn,

Unfortunately vSPhere release were the prerogative of VMware and we could not document or announce support until their GA was confirmed and with the timings this left no time for a documentation respin.

Best wishes,