[drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0

NVIDIA’s framebuffer implementation fbdev=1 is bugged and needs more work.

Whenever my monitor goes to sleep and then gets woken up, I get such errors and Linux virtual consoles die:

[    2.243318] [drm] [nvidia-drm] [GPU ID 0x00000900] Loading driver
[    2.996201] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:09:00.0 on minor 0
[    3.117774] fbcon: nvidia-drmdrmfb (fb0) is primary device
[    3.119036] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[    3.120416] nvidia 0000:09:00.0: [drm] fb0: nvidia-drmdrmfb frame buffer device
[ 1540.529343] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[ 1543.559975] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[ 1546.567978] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[ 1549.704002] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[ 1549.704047] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[23863.160174] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[23863.160211] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[33769.320242] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[33769.320310] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[33772.520598] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[33772.520671] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[34598.382760] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[34598.382818] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22
[34601.518783] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Flip event timeout on head 0
[34601.518847] [drm:nv_drm_atomic_commit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000900] Failed to apply atomic modeset.  Error code: -22

Please fix.

Device: GTX 1660 Ti
Kernel: 6.7.7
NVIDIA drivers: 550.54.14
Monitor: a single 1440p 144Hz VRR display connected via DP
Environment: XFCE (X11) without compositing

options nvidia-drm modeset=1 fbdev=1

Also reported here:

I can trigger this error 100% of the time when I use Serious Editor under wayland(it uses xwayland). When resizing UI windows it auto freezes and after 30-40 seconds I can see it spit errors about flip event timeout, tty cannot be accessed and requires a hard reboot.

You’re right, my text consoles are dead. All I get a single non-blinking underscore. I cannot use any of them.

Can you post the output for

cat /proc/cmdline

This is my output

ro quiet root=/dev/device nothing else. I’m using my own kernel, not Fedora’s.

It’s already discussed here:

A workaround is to load the module from initramfs.

I don’t use initrd, this won’t work for me.

Hi All,
If possible, you can try patch as mentioned in another thread to see if resolves issue.