[550.67] openSUSE 15.5/KDE/X11 " Failed to apply atomic modeset" and "Flip event timeout on head" when switching users

[550.67] openSUSE 15.5/KDE+SDDM/X11 " Failed to apply atomic modeset" and “Flip event timeout on head” when switching users

This seems similar to [545.29.06-18.1]Flip event timeout error on startup, shutdown and sometimes suspend. Wayland unusable, but I decided to report a new issue since wayland is not involved.

OS: openSUSE Leap 15.5
Kernel: 5.14.21-150500.55.52-default
Nvidia driver version: nvidia-driver-G06-kmp-default-550.67_k5.14.21_150500.53-lp155.20.1.x86_64
GPU: NVIDIA GeForce RTX 4060 Ti 16 GB (for deskop PCs).

This is a desktop PC with a single monitor attached via DP. Latest Qt5/KDE5 installed from OBS, I had not switched to Qt6/KDE6 yet.

After driver installation /etc/modprobe.d/50-nvidia-default.conf contains

options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=482 NVreg_DeviceFileMode=0660 NVreg_PreserveVideoMemoryAllocations=1
options nvidia-drm modeset=1 fbdev=1

and neither nvidia-drm.modeset nor nvidia-drm.fbdev are in the bootloader config.

Steps to reproduce:

  1. Perform a cold boot
  2. Login into KDE as user1, start Firefox and Skype.
  3. Suspend and resume your PC.
  4. Logoff. SDDM presents a list of users. Select user2 and login into KDE. Start Google Chrome and Teams (GitHub - IsmaelMartinez/teams-for-linux: Unofficial Microsoft Teams for Linux client).
  5. Attempt to logoff to switch back to user1.

Expected results:
SDDM login manager presents a list of users to login as, etc

Actual result:
Some sort of loop, the display goes black for a number of seconds, then it switches to console mode, I see the root login prompt, but the cursor is not blinking, then the cursor blinks for a second or two, and everything goes black again, repeat. Ctrl-Alt-F1 does not allow to break out of this, only another cold reboot helps. After reboot, journalctl -r shows many “Flip event timeout” messages followed by “Failed to apply atomic modeset. Error code: -22”

kernel: [drm:nv_drm_atomic_commit [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000800] Flip event timeout on head 0

kernel: [drm:nv_drm_atomic_commit [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000800] Flip event timeout on head 0
kernel: [drm:nv_drm_atomic_commit [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000800] Failed to apply atomic modeset. Error code: -22

nvidia-bug-report.log captured after a coold reboot following the issue is attached.

I’ve also experimented with various workarounds mentioned in [545.29.06-18.1]Flip event timeout error on startup, shutdown and sometimes suspend. Wayland unusable

  1. Adding “nvidia-drm.modeset=1 nvidia-drm.fbdev=1” to bootloader config did not help. If anything, it made the situation worse - the issue now happens after attempting to logoff as user 1 in step 4 above.
  2. However, setting nvidia-drm.fbdev to 0 in both bootloader config and /etc/modprobe.d/50-nvidia-default.conf does appear to fix the issue and I was able to perform steps 1-5 without problems.
    nvidia-bug-report.log.gz (825.4 KB)

Added drm.debug=0xff to bootloader config, reproduced the issue with nvidia-drm.modeset and nvidia-drm.fbdev both set to 1, rebooted and generated a new nvidia-bug-report.log which is attached.
nvidia-bug-report.log.gz (895.2 KB)

Also managed to capture the output of dmesg after reproducing the issue with drm.debug=0xff and before the reboot.
dmesg_with_drm.debug.txt (2.0 MB)

Please let me know if there is anything else I could try.