Enable PCIe 3.0 on TITAN with driver 352.63

I was trying to enable PCIe 3.0 with NVreg_EnablePCIeGen3=1 on my TITAN card. But with no luck all the methods did not work.

Here is the specs of my machine:

  • motherboard: MSI X79A-GD65(8D)
  • CPU: Intel Xeon E5-2650
  • OS: Ubuntu 14.04.4 with Linux kernel 4.2.0-34
  • Graphics driver: nvidia linux driver 352.63
  • CUDA runtime: 7.5
  • Here is what I have tried

    1. Append “nvidia.NVreg_EnablePCIeGen3=1” to the kernel boot string. ( I also tried “nvidia_352.NVreg_EnablePCIeGen3=1”. I tried to both add the string in /etc/default/grub and press ‘e’ in the grub page and append the string to the linux line.)
    2. Create /etc/modprobe.d/nvidia.conf and add “options nvidia NVreg_EnablePCIeGen3=1”.
    3. Add “nvidia NVreg_EnablePCIeGen3=1” in /etc/modules. ( I also tried “nvidia_352 NVreg_EnablePCIeGen3=1”)
    4. Add “options nvidia NVreg_EnablePCIeGen3=1” to the existing file /etc/modprobe.d/nvidia-graphics-drivers.conf
    5. Ctrl+Alt+F1 into the text mode and do the following
    sudo stop lightdm
    sudo rmmod nvidia
    sudo modprobe nvidia NVreg_EnablePCIeGen3=1
    sudo modprobe -v nvidia
    sudo start lightdm

    Unfortunately, none of these worked. ( BTW, they all come from these posts
    https://devtalk.nvidia.com/default/topic/523104/linux/linux-pci-e-3-0-support/ )

    Another thing worth of mentioning is that the force-enable-gen3.exe solution on Windows 10 does work (I verified with GPU-Z and from the result of CUDA SDK bandwidthTest). So the hardware combination does support PCIe 3.0 8GT/s.

    I found a lot of people on the forum claiming that they succeeded in enabling PCIe 3.0 using the param NVreg_EnablePCIeGen3 on their Linux system. I am wondering if this is possible on my system. I do not know much about the linux kernel and how device drivers work. Does anyone know the details steps of how to set the NVreg_EnablePCIeGen3 parameter to 1 for the nvidia driver? Thanks.