Enable_perf_measurement [FPS] in deepstream-nvdsanalytics-test sample application

• Hardware Platform (Jetson / GPU) Tesla T4
• DeepStream Version DS 5.1
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only) 460.73.01


I am trying to enable the FPS of the deepstream-nvdsanalytics-test application to display in the terminal as it works in deepstream-app.

I tried the solutions provided by @bcao in the mentioned in the below posts:

I have also made changes to the Makefile as specified in the above post by adding the below line

CFLAGS+= -I/opt/nvidia/deepstream/deepstream-5.1/sources/includes
CFLAGS+= -I/opt/nvidia/deepstream/deepstream-5.1/sources/apps/apps-common/includes

After applying the patch provided by @bcao , the application doesnot compile and shows the below error:

g++ -o deepstream-nvdsanalytics-test deepstream_nvdsanalytics_test.o -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -L/opt/nvidia/deepstream/deepstream-5.1/lib/ -lnvdsgst_meta -lnvds_meta -lnvdsgst_helper -lm -L/usr/local/cuda-11.1/lib64/ -lcudart -lhiredis -lcuda -Wl,-rpath,/opt/nvidia/deepstream/deepstream-5.1/lib/
deepstream_nvdsanalytics_test.o: In function `main':
deepstream_nvdsanalytics_test.cpp:(.text+0x293c): undefined reference to `enable_perf_measurement'
collect2: error: ld returned 1 exit status
Makefile:70: recipe for target 'deepstream-nvdsanalytics-test' failed
make: *** [deepstream-nvdsanalytics-test] Error 1

I have attached my Makefile for reference
Makefile (2.4 KB)

I have also tried the same with the deepstream-test2 app and the error is the same as above.

Can anyone help ?

The “enable_perf_measurement” function is implemented in /opt/nvidia/deepstream/deepstream-5.1/sources/apps/apps-common/src/deepstream_perf.c, you need to build this file in your makefile.

Are you c/c++ developer?


Ill try that too. I posted this here because the solutions provided in the Deepstream SDK FAQ and below link did not work and was checking if there is a patch for the same.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.