Enable PPS on Jetson Linux 35.3.1 for Xavier AGX

My setup (before flash):
Jetson Xavier agx 16Gb
cat /etc/nv_tegra_release → R32 (release), REVISION: 6.1, GCID: 27863751, BOARD: t186ref, EABI: aarch64, DATE: Mon Jul 26 19:36:31 UTC 2021

Hi, I’m trying to enable PPS on JetPack 5.1.1 on out Xavier agx without success. I previously had it working in JetPack 4.4 but I cannot get it to work with the new version.

I have read through every post related to PPS I could find here on the forums and tried every suggested fix, without any success.

Could you please provide a guide on how to achieve this?

Update: related to AGX Xavier PPS fetch timeout R35.2.1(R32.7.1 works fine).

Hi emil.martens,

Are you using the devkit or custom board for AGX Xavier?

Have you refer to the following topic to configure for pps on R35.2.1?
Can’t enable PPS on Jetson AGX Xavier - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums

Can’t enable PPS on AGX Xavier - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums

Hi emil.martens,

You can try to set pps with GPIO_ACTIVE_HIGH, our AGX Xavier works fine with ACTIVE_HIGH

gpios = <&tegra_main_gpio TEGRA194_MAIN_GPIO(A, 0) GPIO_ACTIVE_HIGH>;

Thank you for the suggestion! I’ll give it a try and see if it solves my problems as well! :)

After many more attempts, I finally got it to work!

I think the main things I changed were:

  • Editing source/public/kernel/kernel-5.10/arch/arm64/configs/defconfig directly instead of the .config file with the following

I don’t know if this was all necessary, but now it works as intended.

I made a script that goes through the whole process of enabling PPS, from downloading all the source files to flashing the Xavier. It is pretty hacky and requires sudo privileges, but if anyone wants it, send me a message here or on emil.martens@gmail.com

1 Like

Hi, sorry for the late response; yes, I had red through those posts, but thanks for the suggestion!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.