Enabling the HTTP REST API

I am running Cumulus VX with in GNS3 and can connect just fine. But I’m having issues enabling the API. I keep getting this error after updating the nginx-restapi-chassis.conf file and running the test to check.

nginx: [emerg] "limit_req_zone" directive is not allowed here in /etc/nginx/sites-available/nginx-restapi-chassis.conf:21


To enable the HTTP API, first make sure you are editing the correct file, which is named /etc/nginx/sites-available/nginx-restapi.conf (the file listed above is for chassis platforms only), then follow these steps:

For more information, read the Cumulus Linux user guide.

i am also facing same problem..

Hey there did the solution work for you? You are editing the correct file?