openSUSE Leap 15.5 NVIDIA Repository fails

Hello, I’m on openSUSE Leap 15.5 and NVIDIA repository seems don’t work today, when I try to refresh repositories it gaves me this error message;
Download (curl) error for ‘’:
Error code: Curl error 92
Error message: HTTP/2 stream 0 was not closed cleanly: PROTOCOL_ERROR (err 1)
I tried removing and adding againg few times then tried # zypper clean & ref but none of them solved the problem.
EDIT : It looks like working right now.
EDIT 2: It occured again, I guess it’s about NVIDIA.


I’m also facing this issue. I started facing it on openSuSE: Leap (15.4) and then I upgraded to (15.5) and I still face the same issue simply adding the repository on a fresh install at this point even… any solutions or updates? If it’s an NVIDIA issue do we just wait for them to push some fix? Quite irritating having multiple screens and a high-end GPU but only being able to use one of them right now… going back to Fedora until there is a solution I suppose.

I’ve also been fighting with this problem for a few days but… the (temporary) resolution is incredibly simple.

All you need to do is change the url from “https” to “http”, I did that and lo and behold zypper refreshed the repository and my upgrade to 15.5 worked well and no further problems.

I hope it solves your problem as well. :)




Thanks a lot. I guess it solved my problem as well but I don’t know either if it’s an temporary solution or not.

Thank you for your update, I will try this right now buddy! Cheers!
EDIT: hey Bill, could you post your exact CLI prompt? I just realized I was adding it through YaST, and I don’t have the option to specify ‘http’ vs ‘https’ there. Did you ‘zypper addrepo {/repo}’ and make your change to the link there?

Just delete NVIDIA repository via YaST and use this command;
For Leap:
sudo zypper addrepo --refresh ‘$releasever’ NVIDIA

And for Tumbleweed just change ‘leap’ to ‘tumbleweed’ and delete ‘/$releasever’ in URL.

For Leap 15.4 it is done with the new libzypp, for Leap 15.5 the new libzypp has a broken dependency, but this is known and will be solved soon.

1 Like

Same error with openSUSE Aeon (which is Tumbleweed based so no surprise here).

Looks like nvidia messed up their server or SSL configs.
Would not call it a solution to just disable ssl by using http instead of https.

sudo zypper ref
Retrieving repository 'NVIDIA' metadata ..............[error]
Repository 'NVIDIA' is invalid.
[NVIDIA|] Valid metadata not found at specified URL
 - [|] Error trying to read from ''
 - Download (curl) error for '':
   Error code: Curl error 56
   Error message: HTTP/2 stream 3 was reset

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'NVIDIA' because of the above error.

https seems to be backup running, at least it did refreshed the repo via https for me today.

1 Like

Yes I’m on TW and yesterday I downloaded NVIDIA drivers via https repo. It seems it works without problem.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.