Error flashing Orin NX with DP_6.0

Hi,

I have a Jetson Orin NX 16GB with NVME SSD that I am trying to flash using the SDK manager. I have installed Ubuntu 20.04 to do so.
The first error I can see in the logs is : “failed to read rdm_state”. The logs are attached.

I have no issue flashing the previous release (5.1.3)

Any help would be appreciated.

Thanks,
Antoine
SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-04-02_17-46-37.zip (223.1 KB)

Can you dump the uart log?

Do you use the same usb cable as when you flashed 5.1.3?

Thanks for your answer. Here are the uart logs, as well as the sdk’s logs from the same run.
It’s failing towards the end (usually at around 98%). But my SSD hasn’t been erased, I still have the 5.1.3 / Ubuntu 20.04 installed with all my prior modifications.

Thanks in advance,
Antoine

EDIT: forgot to mention, but the USB autosuspend is already disabled.

SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_NX_modules_2024-04-03_17-27-54.zip (208.3 KB)
uart.txt (80 KB)

Your UART log is incomplete.

So I can see what happen from the uart log is that the target has booted into the kernel initrd. However, your initrd log show that it has not been able to create an usb endpoint that can be detected by the host device like for JP5.1.3

Is that the complete uart log?
Do you use the same USB cable as when you flashed 5.1.3?

Thanks for you answers. Yes that was the entire uart log, I’ve tried again today just to make sure my serial hadn’t dropped, you’ll find the new logs attached.
I was using the same USB cable in both cases yes, and I have also tried with a different, brand new, cable. Same outcome.
Flashing the previous version and flashing an image built with Yocto and meta-tegra works fine.

uart_logs.txt (80 KB)

Does this mean that you just retry this and it flash ok?

Can you try this step and get the flash log?

cd /media/antoine/data-ext4/nvidia/nvidia_sdk/JetPack_6.0_DP_Linux_DP_JETSON_ORIN_NX_TARGETS/Linux_for_Tegra
# put device in recovery mode
sudo ./nvsdkmanager_flash.sh --storage nvme0n1p1 --nv-auto-config --username nvidia
# If flash fail run
ip a
lsusb