Error when installing DeepStream 6.2

• Hardware Platform: Jetson Xavier NX
• JetPack Version (valid for Jetson only): 5.1.1
• Issue Type: questions

Hi, according to this post Internal data stream error when using nvv4l2camerasrc, I was suggested to upgrade latest version of DeepStream and Jetpack.
When I try to upgrade JetPack from 4.5.1 to the newest one, I get errors and solve them according to this post Error when upgrade JetPack - #5 by DaveYYY.
And now, when I try to install DeepStream 6.2 by using the .deb file downloaded from DeepStream SDK - Get Started | NVIDIA Developer, I get the error:

When I try to check the version of Gstreamer and TensorRT, I also get the error like this:

How do you upgrade JetPack version? Could you just use sdkmanager to install Jetpack 5.1.1. The ubuntu version should be 20.04 if you install correctly. You can refer to the link below to install the deepstream step by step:

Hi, I will try install Jetpack by using sdkmanager.
However, do I need to remove all Jetpack versions that exist on the device ? When I run

sudo apt show nvidia-jetpack -a

It displays 3 version on terminal:

  • version 5.1.1-b56
  • version 4.5.1-b17
  • version 4.5-b129.

When I run “sudo apt show nvidia-jetpack”, it just displays the 5.1.1-b56, but the Ubuntu version is 18.04. There are something’s wrong when upgrading JetPack according to this How to Install JetPack :: NVIDIA JetPack Documentation

Oh, for some reasons, I must connect to the Jetson by using ssh, but not diretly use a monitor. I see that sdkmanager using GUI, but I couldn’t. I can just use commands :(

You don’t need to connect the monitor to your Jetson. Sdkmanager is working on your host device. You can refer to the link below: NVIDIA SDK Manager Method

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.