External swap

Hello all.

I’ve been trying to get the thumbs project working after training with a CSI camera.
It keeps freezing and I’ve read from other posts it’s likely to be due to swap.

I’ve tried to increase the size of the swap but it ends up using all the space available on the card and I can’t undo the change or install anything so have to reflash.

I’ve tried allocating the swap size when launching the container as well.

I’ve tried booting from a much faster USB and get the same result. Both sdcard and USB are 32g.

Cloning to a 64g sdcard worked a bit better, but froze too.

I was thinking, why not have the swap on a USB and the OS on the SDCard for some improvement?

I can’t understand why it runs the NVIDIA inference docker and not the simple thumbs tutorial?


Sorry for the late update.

Actually, it depends on the memory usage of your model.
Have you measured the memory amount of your inference task?

If not, please do so.
Since Nano only has 4GB memory, it’s more recommended to use a lightweight model.

And please noted that swap memory cannot be accessed via GPU.
This indicates if you run an inference with GPU, the available memory won’t increase by adding swap.



Its not a Nano 4g, its 2g. I am following the thumbs project in the docker that, as far as I know is made for the Jetson Nano.

Its frustrating, I am trying to complete the Getting Started with AI on the Jetson Nano training but it just wont run on this hardware?

Can I install jetpack on a normal linux PC and run the docker from there?


Unfortunately, the docker is designed for the Jetson platform.
So it won’t be available on the host.

The container can work well on Nano 4GB device.
But for 2GB Nano, it doesn’t have enough resources to deploy training-related tasks.

You can try some inference-only examples instead: