Failed to active WDDM driver mode with K40m in Windows

Hi all, I have a computer, configuration as follows:
Intel Xeon E5-2660v3, 64GB RAM, 2 X NVidia Tesla K40m , onboard AST 1400 VGA as video out.
windows 2008 server r2, windows 7, windows 10

My problem is:
I need to use WDDM driver mode of K40m, by the command:
nvidia-smi -dm 0
After reboot, “nvidia-smi” command shows error as "Failed to initialize NVML: Unknown Error ", but in control pannel - device manager, both “NVIDIA K40M” devices exist.
I edit the windows register table, change both “AdapterType” from 1 (means WDDM) to 2 (meas TCC), after reboot both devices are shown again in “nvidia-smi”.
If I active wddm for one k40m by
nvidia-smi -g 0 -dm 0
After reboot, only one k40m with TCC mode shows in “nvidia-smi”, the other one in “WDDM” mode is not recognized.Also both device can be found in control pannel - device manager.

I’ve tried windows 2008 server r2, windows 7, windows 10, and the corresponding nvidia drivers for tesla or quardro with diffrent versions from nvidia web site.Unfortunately all fail with the same error.
Both k40m function correctly in TCC mode, both in Linux and in Windows, but not successful in WDDM mode for Windows.
4G Mapper is enabled in BIOS.

Anyone who can help will be greatly appreciated.

WDDM driver mode is not supported on K40m in windows.

http://i2.buimg.com/4851/d4eeaf418883f7b2.png

That might have been a weird bug more than anything else? Not sure what that mode means on a device with no graphics outputs at any rate…

Not only does it have no graphics outputs, but it reports itself in PCI config space as a 3D controller, not a VGA controller. This is verifiable in windows with a config space reader (or by sifting through device properties) and in linux with lspci.

Good luck getting a proper windows display driver stack built on a device that does not have a VGA classcode!

A 3D controller looks like this in lspci output:

04:00.0 3D controller: NVIDIA Corporation GK110BGL [Tesla K40m] (rev a1)

A VGA controller looks like this:

04:00.0 VGA compatible controller: nVidia Corporation Device 107d (rev a1)

Thanks for replying.
The reason why I wan’t enable WDDM for a K40m is that my Windows applications need opengl (>=3.2) support. A K40m in WDDM mode will enable opengl calculations, but opengl library will not available in TCC mode.

txbob gave an important hint: to get a proper windows display driver stack built on a device that does not have a VGA classcode !
Would you plz me more information on how to do that, or is it possible to HACK any driver to remove or fake a suitable VGA classcode ?

Many thanks !

The easy solution is to use a Quadro K6000 instead of the K40m.

Presumably the system containing the K40m (passively cooled) is inside some sort of server enclosure, which may not be an appropriate physical environment for a Quadro K6000 (actively cooled)?

My suggestions would be for the OP to check with their system vendor about other GPU options appropriate for their particular system.

hmm, yeah, a Quadro solution would be very nice. A wired thing is I managed to activate WDDM for K40m, BUT cannot duplicate this success any more. I still don’t know what happened, just failed an another machine, the same hardware/OS environment.