Failed to set node GUID of VF (SR-IOV)

Related files:

https://community.mellanox.com/s/article/Docker-RDMA-SRIOV-Networking-with-ConnectX4-ConnectX5-ConnectX6

Problem:

I created 4 VFs on SR-IOV and let OpenSM support virtualization, but currently all VFs’ port state are still down, so I tried to configure node GUID, port GUID and policy GUID. However, when I excuted command “echo 00:11:22:33:44:55:1:0 > /sys/class/infiniband/mlx5_0/device/sriov/0/node”, it failed. Then I tried to enter and edit this file by vim, it reported error log as follows.

Please ask what should I do next? Thank you very much!

Hi ,

Please refer to the below guides :

https://community.mellanox.com/s/article/howto-configure-sr-iov-for-connect-ib-connectx-4-with-kvm--infiniband-x

https://community.mellanox.com/s/article/HowTo-Configure-SR-IOV-for-ConnectX-4-ConnectX-5-ConnectX-6-with-KVM-Ethernet

Important notes :

  • Make sure that intel_iommu=on is added to /boot/grub/grub.conf
  • Make sure that the openSM is enabled with virtualization.

virt_enabled 2

Thanks,

Samer

Hi ,

Are you able to set the SR-IOV VFs ?

Thanks,

Samer

Thank you very much, we have solved the problem.​ We need to unbind and rebind VFs, and also need to make sure that opemd is active.