ffmpeg -f kmsgrab is failing: Failed to open DRM device.

Hi’m exploring game/desktop capturing via ffmpeg.
Unfortunately i noticed that when the gpu use is high and i capture the desktop via x11grab, the whole thing starts to stutter a lot, so i wanted to try kmsgrab instead.
Unfortunately, it is not working, see:

koko@slimer# sudo cat /sys/module/nvidia_drm/parameters/modeset
Y

koko@slimer# sudo setcap cap_sys_admin+ep /usr/bin/ffmpeg 

koko@slimer# ffmpeg  -device /dev/dri/card0 -f kmsgrab -i  - -f image2pipe -
ffmpeg version n4.2.1 Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 9.2.0 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdav1d --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-nvdec --enable-nvenc --enable-omx --enable-shared --enable-version3
  libavutil      56. 31.100 / 56. 31.100
  libavcodec     58. 54.100 / 58. 54.100
  libavformat    58. 29.100 / 58. 29.100
  libavdevice    58.  8.100 / 58.  8.100
  libavfilter     7. 57.100 /  7. 57.100
  libswscale      5.  5.100 /  5.  5.100
  libswresample   3.  5.100 /  3.  5.100
  libpostproc    55.  5.100 / 55.  5.100
[kmsgrab @ 0x56355affb7c0] Failed to open DRM device.
pipe:: Invalid argument

Is that expected?

Could, please, a developer jump in and tell me if i can stop to try to make it work as it is supposed to not?

i modified my system configuration to disable nvidia modeset:

koko@slimer# sudo cat /sys/module/nvidia_drm/parameters/modeset
N

Now ffmpeg is failing in another way:

[kmsgrab @ 0x5580a46c64c0] Failed to set universal planes capability: primary planes will not be usable.
[kmsgrab @ 0x5580a46c64c0] Failed to get plane resources: Operation not supported.

…similar results with:
https://github.com/jsastriawan/kmsfbshot

#sudo ./kmsfbshot
Unable to retrieve DRM resources (95).

Snippet of the code producing the error:

res = drmModeGetResources(fd);
    if (!res)
    {
        fprintf(stderr, "Unable to retrieve DRM resources (%d).\n", errno);
        return -errno;
    }