Flash to NVMe success but Xavier can't bootup and got failed message: "ERROR: PARTUUID=73999e04-4fc4-42bb-96ed-102c108888eb mount fail..."

Hi NV_Team,

I have followed README_initrd_flash.txt [Workflow 3: How to flash to an external storage] and Flashing to an NVMe Drive to flash JetPack4.6 to Xavier NVMe drive.

Flash to NVMe success [l4t_initrd_flash–flash-only.jetson-xavier-nvme0n1p1.20210926.log] but Xavier can’t bootup and got failed message: “ERROR: PARTUUID=73999e04-4fc4-42bb-96ed-102c108888eb mount fail…” [detail bootup message refer to [Uart_Log_Xavier_NVMe_bootup_2021_9_26_15-44-11.TXT]

NVMe PartNumber: Lenove X800 128GiB M.2 NVMe SSD

Steps to flash Xavier NVMe:
1. sudo ./tools/kernel_flash/l4t_initrd_flash.sh --no-flash jetson-xavier external 2>&1 | tee l4t_initrd_flash--no-flash.jetson-xavier-external.20210926.log

(Set Xavier Devkit in recovery mode)
2. sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c ./tools/kernel_flash/flash_l4t_nvme.lenovo.x800.128GiB.xml -S 128GiB --flash-only  --showlogs  jetson-xavier external 2>&1 | tee l4t_initrd_flash--flash-only.jetson-xavier-external.20210926.log

flash_l4t_nvme.lenovo.x800.128GiB.xml (8.3 KB)
l4t_initrd_flash–no-flash.jetson-xavier-external.20210926.log (126.9 KB)
l4t_initrd_flash–flash-only.jetson-xavier-nvme0n1p1.20210926.log (62.0 KB)
Uart_Log_Xavier_NVMe_bootup_2021_9_26_15-44-11.TXT (98.7 KB)

Please help to check it.

Hi Luna2020,

In “flash_l4t_nvme.lenovo.x800.128GiB.xml” file, the num_sectors * sector_size need to be higher than -S size.
Check your xml, the size is set 119GB, but you set -S=128GiB.
Please change -S size and run again. Thanks!

APP-size is the size of the partition that contains the operating system in bytes. KiB, MiB, GiB shorthand are allowed, for example, 1GiB means 1024 * 1024 * 1024 bytes. This size cannot be bigger than “num_sectors” * “sector_size” specified in the and must be small enough to fit other partitions in the partition layout.

Hi carolyuu,

I change 128GiB to 118GiB and 100GiB, still get the same failed boot-up log.

ERROR: PARTUUID=73999e04-4fc4-42bb-96ed-102c108888eb mount fail…
 sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c ./tools/kernel_flash/flash_l4t_nvme.lenovo.x800.128GiB.xml -S 118GiB --flash-only  --showlogs  jetson-xavier nvme0n1p1 2>&1 | tee l4t_initrd_flash--flash-only.jetson-xavier-nvme0n1p1.20210926.log

Hi Luna2020,

We can’t reproduce your issue with r32.6.1 on Xavier-NX.
Test with set -S=8GiB and num_sectorssector_size=28GiB*, it can flash and boot up success.
Test pipeline:

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c ./tools/kernel_flash/flash_l4t_nvme.xml -S 8GiB --showlogs jetson-xavier-nx-devkit-emmc nvme0n1p1

Please format your NVMe to ext4 format from host ubuntu machine and try again.

Hi carolyuu,

I have fixed it by modify the correct part-uuid located Linux_for_Tegra/bootloader/l4t-rootfs-uuid.txt_ext

Thanks.

1 Like