Jetson Xavier NX flash to nvme / flash bootloader only

Hi, I use Jetson Xavier NX.
Jetpack: Jetpack 5.1.2
TOOL: SDKManager or Linux_for_Tegra
Storage: NVME

My project require large size.
So I use NVME.

First, I want to flash OS image to NVME but when flash using SDK Manager to nvme, It create partition only 14GB. Is it not fixed yet?

Second, I have mounted nvme. So I flash only bootloader which knows rootfs is nvme and os in nvme.
I tried

sudo ./ -r jetson-xavier-nx-devkit nvme0n1p1

but It is not work. After 10min, still this state. like this.

and after 15~20min change log like this

This takes too much time.

Can these problems be solved?


Okay, I will try.

Then Why is showing error?
When I try flashing only bootloader does not support flashing to NVMe/USB drive; you should use initrd flash, or just let SDK Manager do the work.
It has nothing to do with flashing only bootloader.

Thanks. but I change xml_config to flash_l4t_t234.xml from flash_l4t_external.xml
and flash using SDK manager.

Result is same. manager create partiion. I want use all strage size, not partiion.

Read the reply more closely.
You should change this section:

		if [[ "${target_board}" == *"jetson-xavier-nx-devkit"* ]]; then
			echo "Flashing Jetson Xavier NX"
			options=("--external-device" "${storage}" "-c" "${xml_config}" "--showlogs" "--network" "usb0")
			ADDITIONAL_DTB_OVERLAY_OPT="${OVERLAY_DTB_FILE}" EXTOPTIONS="${EXTOPTIONS}" "${curdir}"/"${initrd_path}" "${options[@]}" -p "--no-systemimg -c bootloader/t186ref/cfg/flash_l4t_t194_qspi_p3668.xml" "${target_board}" internal

Not this:

set -o pipefail;
set -o errtrace;
shopt -s extglob;
curdir=$(dirname "$0");
curdir=$(cd "${curdir}" && pwd);

We are talking about flash_l4t_t194_nvme.xml, not flash_l4t_t234_nvme.xml.
Is that clear for you?

1 Like


I followed the answer and it runs perfectly.

Thank for your advice.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.