Space Error When Flashing and Installing SDK on nvme SSD in NVIDIA Jetson Xavier NX

I am encountering a problem with my NVIDIA Jetson Xavier NX. I’m trying to flash and install the SDK on nvme SSD, but I keep getting a “no space left” error when installing the modules. The SDK Manager seems to automatically set a 14GB APP partition, which is too small for the installation.

Here’s what I’ve tried so far:

  • Using with the -S flag.
  • Modifying .xml file configurations.

None of these methods have resolved the issue. How can I successfully flash and install the SDK on my SSD with an adequately sized APP partition(I have 100gB in UAD partition)? cannot flash external drive. Please use initrd flash instead.

The problem still exists of the size of APP partition being 14 Gib Only.


You need to use flash_l4t_external.xml instead of flash_l4t_t194_nvme.xml.

Worked THanks!!
Sdkmanager didn’t work but used directly

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.