GDR create less slices than expected


I tried to enable the GDR and getting problematic behavior, The GDR set to 10 slices so the normal behavior is to get 9 slice of ‘P’ frames and 1 ‘I’ frame, instead the GDR give only 2 ‘P’ frames and 1 ‘I’ frame.
In the encoder on Quardo and Geforce the GDR work as expected,
It’s a bug or Feature? :)

There is minor deviation between Jetson platforms and desktop GPUs. Please check the explanation in
GDR in H265 encoding not working as expected - #9 by DaneLLL

Thank @DaneLLL for the quick answer.
The explanation was great but my topic is slightly different, I don’t have a problem with the bumber of the GDR slices, I have problem with the number of the’P" NLU packets per frame, for example:
Lets said that GDR set to 10 slices,

Expect behavior:
Frame 0 - 1 ‘I’ frame than 9 ‘P’ frames,
Frame 1 - 1 ‘P’ frame, than 1 ‘I’ frame, than 8 ‘P’ frames,
Frame 2 - 2 ‘P’ frame, than 1 ‘I’ frame, than 7 ‘P’ frames,
Frame 3 - 3 ‘P’ frame, than 1 ‘I’ frame, than 6 ‘P’ frames,

Actual behavior:
Frame 0 - 1 ‘I’ frame than 1 ‘P’ frames,
Frame 1 - 1 ‘P’ frame, than 1 ‘I’ frame, than 1 ‘P’ frames,
Frame 2 - 1 ‘P’ frame, than 1 ‘I’ frame, than 1 ‘P’ frames,
Frame 3 - 1 ‘P’ frame, than 1 ‘I’ frame, than 1 ‘P’ frames,

This behavior cause me a lot of trouble, I will appreciate if you find way to set it right.

Do you use latest Jetpack release? It sounds similar to this:
Jetson Nano multimedia API example 01_encoder with gdr - #10 by rafi.agiv1

If you use previous release, please upgrade to 4.6 or 4.6.1 and try again.

I am working on 4.6.1

Please share a command so that we can run 01_video_encode to generate the stream. Do you encoding to h264 or h265? The behavior on AGX Xavier should be good so this probably is specific to using Jetson Nano. We would need to do further check.

Hi @DaneLLL

The command is:
./video_encode ~/Videos/motorcycle_300_frames.yuv 1920 1080 H265 test.h265 --egdr -gdrf gdr_params.txt -idri 1000 -ifi 1000 --input-metadata
The gdr_params.txt: 12 12

I also tried on AGX and faced same problem.

Please check if we understand your request correctly. So you can see I slices are spread into P frames like:

But you would like the P frames is divided into several P slices like:

Is this correct?


We have checked with teams and confirmed the mode you request is not supported. Please consider use the existing mode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.