GPU metrics error

When I check GPU metrics following error occurs.
What does “[QuadDCommon::tag_error_code*] = 17” mean…?

AnalysisService: failed to start event source Perf: /build/agent/work/20a3cfcd1c25021d/QuadD/Target/quadd_d/quadd_d/jni/EventSource/GpuMetricsInternal.cpp(800): Throw in function void QuadDDaemon::EventSource::GpuMetrics::Internal::Start(const std::shared_ptr&, uint32_t, const std::function&)
Dynamic exception type: boost::wrapexcept
std::exception::what: InternalErrorException
[QuadDCommon::tag_error_code*] = 17
[QuadDCommon::tag_error_text*] = Insufficient privilege
[QuadDCommon::tag_api_function*] = NVPW_Device_PeriodicSampler_BeginSession(&beginSessionParams)
[QuadDCommon::tag_debug*] = 1

Host
Ubuntu 18.04.5 LTS
Nsight Systems 2021.2.1

Device
Ubuntu 18.04.5 LTS
Tesla T4
CUDA 10.2

If I set SSH ID as root, profiling is stopped by itself with following message.

Number of incomplete CUPTI events dropped: 465. Incomplete events appear when GPU timestamp information have not been retrieved at the time the profiling session was stopped.

I’m suffering from the same error message. Have you heard anything back from anyone?

not yet… :(

same error. unsolved yet…

I’m having the same issue.

I am sorry that there was no response to this earlier, your forum post was dropped in an orphaned category that the Nsys team was unaware of until this afternoon.

@andrey_trachenko can you answer this?

Hello, GPU metrics sampling needs administrative/root privileges of special setup for non-privileged users. For details please see NVIDIA Development Tools Solutions - ERR_NVGPUCTRPERM: Permission issue with Performance Counters | NVIDIA Developer.