GTX 470 deviceQuery reports a Clock Rate of 0.81GHz

When I run deviceQuery.exe, CUDA 3.1b and now 3.1 are reporting my GTX 470 always has a clock rate of 0.81 GHz.

Two other cards in the workstation report the expected clock rate.

However, utilities like GPU-Z that presumably use NVAPI also report the expected and correct clock rate for all cards.

My GTX 470 is factory over-clocked at 625/837/1250 (gpu/mem/shader). It’s a Galaxy GTX 470 GC.

I assume this is a CUDA device query API bug and could complicate choosing from multiple devices at run time. NVAPI seems to get it right.

Otherwise the card runs kernels at full speed.

deviceQuery.exe output:

[indent][font=“Courier New”]

Device 0: “GeForce GTX 470”

CUDA Driver Version: 3.10

CUDA Runtime Version: 3.10

CUDA Capability Major revision number: 2

CUDA Capability Minor revision number: 0

Total amount of global memory: 1309212672 bytes

Number of multiprocessors: 14

Number of cores: 448

Total amount of constant memory: 65536 bytes

Total amount of shared memory per block: 49152 bytes

Total number of registers available per block: 32768

Warp size: 32

Maximum number of threads per block: 1024

Maximum sizes of each dimension of a block: 1024 x 1024 x 64

Maximum sizes of each dimension of a grid: 65535 x 65535 x 1

Maximum memory pitch: 2147483647 bytes

Texture alignment: 512 bytes

Clock rate: 0.81 GHz

Concurrent copy and execution: Yes

Run time limit on kernels: No

Integrated: No

Support host page-locked memory mapping: Yes

Compute mode: Default (multiple host threads can use this device simultaneously)

Concurrent kernel execution: Yes

Device has ECC support enabled: No

[/font][/indent]

More info:

    810MHz is one of the several speeds the GPU downclocks to when it idles.

    810MHz appears to be the highest downclocked speed. 1250MHz being the normal speed.

    the GTX 470 card at issue is running headless

    I can confirm that it was running at full speed when deviceQuery.exe was run

Final side comment, I seem to have no problem overclocking the card up to 800/1600 (gpu/shader)! I only tried it for 30 minutes but there were no problems.