GTX285 + recent drivers (285.15) + Ubuntu 13.04 x64 = intermittent compiz hangs

The most common situation for this hang is a compiz desktop wall plugin-based viewport switch between workspaces, but I’ve observed it (rarely) in other situations. The symptom is that the screen freezes mid-animation, the compiz process goes to 100+% cpu, and dmesg outputs one or more of the following message:

[1298393.855931] NVRM: Xid (0000:01:00): 56, CMDre 00000001 00000080 00000000 00000005 00000006
[1298393.855943] NVRM: Xid (0000:01:00): 56, CMDre 00000002 00000080 00000000 00000005 00000006

It never recovers by itself, though it appears to try as often the mouse cursor will begin moving again and a frame or two of screen update happens. Sometimes C-A-F1 will work, letting me kill compiz. Otherwise, ssh from another machine works to recover.

The attachment includes several such hangs with compiz-kill-restart sessions.

Hardware is a single GTX285 driving two monitors 1920x1200 in TwinView mode.
nvidia-bug-report.log.gz (76.7 KB)

Hi mthome,

Do you have steps that reproduce this problem reliably, or does it only happen sometimes? How exactly (i.e. specific key presses or mouse movements / clicks) do you trigger the desktop wall and perform the switch?

No - there is no reliable repro. The freeze occurs mid “slide” transition between workspaces, after (for instance) a C-A-rightarrow to shift to the next workspace to the right. I would guess something like 5% of the desktop shifts result in this condition - yesterday it happened to me 3 times, I think, over the course of a work day. The other (much rarer) situation I see apparently the same situation is when dragging windows between workspaces while in expo mode.

FWIW, my compiz opengl settings have framebuffer and buffer swapping enabled with “good” texture filter on.

Thanks, mthome. Can you please experiment with the compiz settings to see if any particular setting triggers or eliminates the problem? I filed bug 1376210 to track attempting to reproduce the problem.

Does this problem also occur with older drivers?

I’ve tried a variety of drivers - it has been happening since I updated to 12.10 or thereabouts, though the frequency of freeze has dramatically increased in the last few weeks, I presume due to one of the kernel updates. Sadly, I don’t have the luxury of the downtime needed to do a bisection with all the variables. Are there particular driver parameters, x11 settings, or compiz settings that you’d like me to try?

Bump.

Additional observations:

  1. No settings I’ve tried have eliminated the problem. Minimizing time spent doing compiz effects does, of course, minimize the frequency of the hangs. An obvious workaround is to turn off compiz completely, but that isn’t a fix.
  2. A possibly interesting coincidence is that often when compiz is frozen, one or more chromium processes are moderately busy as well (>10% of a core but < 50%). In these situations, once killing compiz and allowing it to restart, chromium reports that an associated window died (with an “oh snap” error).

We are not able to repro this issue. Is there any more information that we help to repro this issue?

  1. Cannot reproduce on:
    • Drivers: NV Driver 325.15
    • OS: Ubuntu 13.04 Kernel 3.8.0-19-generic
    • Cards: GeForce GTX 285
    • System: Dell SBIOS A06 system
    • Monitor: 2x Lenovo 2251p
  2. Repro Steps:
    1. Boot Ubuntu.
    2. Enable Compiz wall by going to System Settings->Appearance, then going to the Behavior tab and checking “Enable workspaces”
    3. Create windows on every display in each viewport
    4. Create an xmacro to switch between viewports, run on a loop
  3. Additional Information: Test ran >10000 times over the weekend on a loop.
  4. Links or info to tools or apps needed to repro: xmacro was helpful in attempting to repro, should be available viaapt-get install xmacro

Hi mthome, Could you please provide requested information?

This issue no longer repro with GTX 285 + UBUNTU 13.04 + Dell U2410 [2 monitors] + 325.15 + ssytem Dell T5500

How frequently you are facing this issue? I ran the test over weekend. No repro.

I’ve not been seeing the problem because I’ve disabled compiz effects (work critical machine). I will re-enable and see what happens.

That didn’t take long. I’ll attach another crashlog. This one was due to dragging a window between desktops. Failure mode is the same with the same nvidia-related kernel error. I did try a whole slew of desktop switches without a crash (not automated though).
nvidia-bug-report.log.gz (2.36 MB)

Could you please share compiz version?

mthome, Waiting for your reply. We are not able to repro this issue. Any clue to repro this issue? I haven’t seen update since long time.