334.21 and Ubuntu 13.10 - screen artifacts and freezes

Installing of any 334.xx driver on Ubuntu 13.10 (and 14.04) leads to screen artifacts. Menu items become active on mouse overs and remain active forever. Working in terminal is impossible, especially in Midnight Commander. And after several minutes of working Ubuntu freezes completely.
Has anyone else experienced anything similar?
PS: Sorry for my terrible English.

Besides the freezing it sounds suspiciously similar to what is being described here-
https://devtalk.nvidia.com/default/topic/700104/linux/screen-jittering-with-334-21/

Are you using Unity Deskop?

Yes. Standard Ubuntu 14.04 with Gnome 3 and Unity. I suspect that this bug isn’t in the driver itself but is in some Ubuntu’s GL or xorg lib. However, I hope that NVidia Linux community will be able to find the solution ^_^
And you’re absolutely right - I’ve read that thread before and many other similar threads related to 334.xx. Unfortunately, no solution has been found, all those threads seem to be dead. So I decided to create this one.

I did find this- https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1288747
it sounds like the same thing. I’ve added myself as affected, you should too! I’ve got a feeling since we are running the newer driver which is not in the Ubuntu repos yet this might be put on the backburner for now. At least it’s been reported and hopefully soon it will get fixed. As a workaround you could enable “force fullscreen redraws (buffer swap) on repaint” in the “Workarounds” plugin in Compizconfig Settings Manager. This seems to eliminate the issue for me and despite the warning that it will cause a massive increase of gpu and cpu usage, I haven’t noticed any difference.

Done ;)

Oh, it sounds interesting. I’m using 331.49 now, but I’ll try your solution when I’m forced to update the driver.