[390.25] Random flicker in mid screen when deskop is mostly idle/empty.

I started seeing a random flicker for a fraction of a second every few hours in Gnome 3.26 after upgrading to 390.12 driver. It mostly happens when the desktop is empty and probably at low clocks.
I downgraded to 384.111 and couldn’t see it. it’s also not an issue on 387.34.
That means the issue started in 390.12

Same issue here with MATE 1.18 desktop. Tried with and without compton. With and without ForceCompositionPipline. I do have 2 screens and this only seemed to happen on my main monitor which is 2560x1440 @144hz, tried lowering refresh rate as well but nothing fixed it. Downgraded to 387.34 atm which doesn’t seem to have that issue.
Couldnt see anything weird in dmesg or xorg logs either, so no clue how other people can reproduce this.

IIRC, there was a bug some time ago that caused flicker at idle clocks on Gainward cards. Maybe that came back, so what brands are your cards?

Mine is a Zotac 1050Ti.
I saw this bug (or something similar) months ago and they quickly fixed it so it may have indeed regressed again.
@generix, your comment about idle clocks may be it since if I have something actively drawing on the screen, no flicker happens.

I downgraded to 384.111 and no glitches in the last 20+ hours.

Edit:. fixed sentence.

EvGA GTX 1070 here. Never seen this issue before with any drivers. Have this card from July 2016.

Also for me it doesn’t only happen on desktop and on idle clocks. Played some games Hitman, Rust and so on and had the flicker there also. Like a big black bar flickers for sec on top section of the screen for me and it happened every 5-10 minutes.

edit: more info added

Issue still in 390.25 driver.

do you use forcecompositionpipline? i had this issue also after switching to 390.25 but now it dissapeared after i changed from ForceCompositionPipline to ForceFullCompositionPipline

will need to do more testing obviously.

Ok, it now says:

Option "metamodes" "nvidia-auto-select +0+0 ForceFullCompositionPipeline=On}"

I will report back after testing. Thank you very much for the suggestion, Xpander. I appreciate it.

you are missing few brackets :)

Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

also you can just enable it from nvidia-settings for testing, so reboots (X restarts) are not needed.
adding to xorg will make it permanent option ofc.

So far i haven’t noticed this issue anymore, but more testing is still needed as with 390.12 i did not get this issue until 1-2 days of using my machine.

Ok, I edited it. Thanks again. Yes, I understand it is very sporadic and it may take a few days to verify it indeed helps.

It happened again. The screen almost flashed or flickered or dimmed for a fraction of a second.

still none for me. try under nvidia-settings “X Server XVideo Settings”
set sync to your monitor instead of auto, thats what i also changed, but i dont think that matters

my settings are atm:

xpander@arch ~ $ cat /etc/X11/xorg.conf.d/00-nvidia.conf 
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070"
    Option         "Coolbits" "28"
	Option         "metamodes" "DP-4: 2560x1440_144 +0+0 { ForceFullCompositionPipeline = On }, DP-3: nvidia-auto-select +2560+0 { ForceFullCompositionPipeline = On }, DP-1: off "

I have those flicker on transparent windows (Terminal, Conky) and desktop as well. “Solid” windows seem to be unaffected. But it only occurs on my left monitor (Dual Monitor setup). Changing ForceCompositionPipeline to ForceFullCompositionPipeline haven’t fixed it for me, but it seems to have got rid of the extreme flickering (still needs to be observed for longer).

With ForceCompositionPipeline I’ve had really bad flicker (Black/Normal several times in a second), with ForceFullCompositionPipeline it is still there but without the many flickers, but windows/desktop still went black at times.

Switching the the Sync between monitors and auto doesn’t do the trick for me.

I’ve had very rarely black windows with 384 on my old 970 and my new 1080, but 390 makes it really worse.

Desktop: Cinnamon
Distribution: Linux Mint 18.3
GPU: KFA2 GeForce GTX 1080 EXOC

I get something similar, during compositing start (from login screen to Gnome desktop) I get some weird color flashes.

MSI 970 390.12. This is the driver I noticed it from on Archlinux.

ok, still having this issue while gaming. its not severe, but happens from time to time. tried to record it also but nothing shows up on the recording. Something with ForceComposition is broken in this driver i guess.

I’ve seen this happen too. It seems to only happen for me at lower framerates.

If I’m playing a game on one screen and the framerate dips below 25 FPS, it starts to do it. It’s more noticeable on the secondary display but it happens on the primary screen (which is running the game) as well.

It’s easy to duplicate on my end by running Unigine Superposition on the 1080p Extreme preset.

This happened on both 390.12 and 390.25 on a GTX 1080 with ForceFullPipelineComposition enabled.

I’m tracking this in internal bug #2053567.

yeah after a bit more testing it seems it doesn’t happen when ForceComposition is disabled and it happens when ForceComp or ForceFullComp is enabled. With FUll it happens way less, i guess that depends what compositior your DE is using etc.

I’m Using MATE with simple compton conf

encountered same issue yesterday with 390.25 driver. On KDE environment.
Gigabyte 1080Ti Extreme edition

I’m seeing the same flicker on a secondary monitor when it’s being captured with a virtual loopback device.

This is with 390.25 and kernel 4.15 on Ubuntu 17.10 + XFCE4… with compton.