Screen flickers at PowerMizer level 0 - GTX 760/770

Intro
As the title says I started getting screen flickering whenever my GTX 760 hits level 0 power mode. The problem only exist in the Nvidia driver 384. I was unable to reproduce the issue when downgrading to driver version 381. I tried lowering the refresh rate to 60 Hz but with no effect. Tested this on the LTS kernel for arch but no difference there. As you can see in the attached video, whenever the power profile gets to level 0 the screen starts to flicker.
This bug looks very similar to the one discussed here: https://devtalk.nvidia.com/default/topic/1016162/linux/occasional-solid-color-flashing-flickering-with-gtx970-on-384-47/1. only the problem is said to be fixed on the latest driver.

System Info
I am running Arch Linux 64 Bit with the Gnome DE but also tried KDE where the problem is also present. As mentioned above I am currently on Nvidia driver version 384.59 with kernel 4.12.4. I have my system hooked up to a Asus 144 Hz 1080P monitor via Display Port cable.

How to reproduce
You can reproduce the bug by running driver 384 with GTX 760 card and setting the PowerMizer to Auto or Adaptive. When the system stabilizes and the Power profile gets to level 0 the flickering then begins.

Video of flickering
https://youtu.be/KwHhIU4x-3U
nvidia-bug-report.log.gz (240 KB)

I have exact the same problem. Same gpu, same operating system, same driver version, and same solution by downgrading to 381. I also tested with a bunch more different desktop environments and they all exhibited the same problem (i3, xfce).

Same issue here with a GTX 770 (arch 64, nvidia driver 384.59, kernel 4.12.4, display is an HP 22" LCD on DVI-I-1). Prior version of the driver didn’t show this problem.

I was able to find a workaround: as soon as GPUCurrentPerfLevel hits value 0 and the screen is flickering (a lot!), I start glxgears which then stops the flickering and puts the PerfLevel back to 3 (in my case) for a time. When the PerfLevel gets back to 0 the flickering does no longer appear. If I kill the running glxgears the flickering comes back as soon as the PerfLevel is back to 0.

Hi all, Please run and attach nvidia bug report log as soon as issue hit. What desktop env you are running Please share o/p of dmidecode comamnd . Make sure to blaklist nouveau. Looks like you are running DP monitor with resolution 1920x1080. How long it takes to reproduce this issue? Any special setting needed ?

Hello

dmidecode: https://framadrop.org/r/KHvNVO1kLy#bhIw7ZUSbh0nUr5g/Jv+mGjZf+kAp4Ts3d7cw+ErZTg=
nvidia bug report: https://framadrop.org/r/WjAnz8UkCF#YIzlPrIikccjdQM5k1GkFoYWJA3lmS2IAE5OpC1LlB4=

Concerning your other questions, my desktop is fluxbox, nouveau driver is blacklisted, my monitor has a resolution of 1680x1050@60Hz and the bug appears as soone as the power level of the graphics card drops down to 0 (as shown by GPUCurrentPerfLevel). I have no special setting.

If you need anything more, let me know.

Same story here. Any kind of workaround in the meantime?

Not at home now, but

nvidia-settings -a [gpu:0]/GPUPowerMizerMode=1) &

should work?

Thanks all for reporting this issue. Make sure to blacklist nouveau driver. Please run nvidia bug report as soon as issue hit and attach. I also please confirm reverting back to 381 fix the issue. Please also provide reproductions steps if there any change. Share info about Monitors and connection type to GPU like hdmi or dvi or dp etc ? Is the issue reproduce with single monitor? What desktop evn you are running like gnome, kde, unity, xfce etc. ?

I have filed bug 200337553 to track this issue. Please provide as much as info so we can reproduce this issue for investigation.

@Sandip
Sorry but I can’t test a multi-monitor setup. However, I tested multiple resolutions and refresh rates, up to 1920X1080@144 Hz and only with progressive update as time fell short to do interlaced. The flickering bug was present at all resolutions I tried.

In NVIDIA X Server Settings I switched from ‘Prefer Maximum Performance’ to ‘Auto’ and as soon as it hits Level 0, flickering starts again.

GTX 760
Eizo S2433W on DP-1 with 1920x1200
(also happens with second monitor on DVI, if turned on)
Driver Version: 384.59
kernel: 4.12.4-1-ARCH

Log: https://framadrop.org/r/c6lirvOvxu#JycSdtPntrnrt9prJeYzHXrsNRVKOarYpOzYZIgPuZg=

Hi all,
We are not able to reproduce this issue with straight forward method. Do I think need run something on desktop to trigger this issue? Is see one user using os in uefi mode and other are in legacy mode. Is the issue reproduce on newly installed fresh os also with nvida .run driver package?

[i]Below are the update from our QA:

Not able to reproduce this issue with GTX 770 Gigabyte OC card + Dell Precision T7910 + ARCH Linux with Kernel:4.12.4.1 + 384.59.

Here the reported user VBIOS: 80.04.c4.00.15 – GTX 760, 80.04.c3.00.38 – GTX 770, 80.04.c4.00.13 – GTX 760

We are not able to find any Galaxy / Pailt OEM’s GPU [GTX 760 / 770]. I got EVGA GTX 760 , flashed nearby VBIOS [80.04.c4.00.19] of reported user, Still no luck. Will keep the system running over night and confirm the results tomorrow. [/i]

Hi all, Any update about requested info in comment #10 ?

Hi Sandip
I just came home today and updated my system to Nvidia 384.59-5 from the official Arch repo and I still have the bug. I’ll try to make a partition for another instance of arch to test the Nvidia drivers on a clean install. It might take a little time though.

I’m having the same problem when using GTX 760 with 4.12.8-2-ARCH and 384.59, had to go back to 4.11/381 which works fine.

Hi again
I just tried to run Ubuntu 17.04 on the same PC. It’s a completely fresh install and once again when I install Nvidia driver 384.59 the screen flicker comes right back. I made a new report when the flickering began.

How to reproduce
Install a Ubuntu 17.04 and update the system. Then install Nvidia driver 384.59. Reboot and then the flickering begin when the GPU goes into the lowest power state (0).

As a side note the Linux Kernel version is 4.10.0

EDIT
I tried to uninstall the driver from the repo and instead install it manually, but this again made no difference.

nvidia-bug-report.log.gz (210 KB)

this problem is present in new drivers 384.69

Ok question for nvidia developer what are new in 384.69 ?
i’m still have old problem
Screen flickers
No audio via displayport

Please share nvidia bug report log file as soon as issue hit. We are trying repro by matching config you guys using. Also what desktop env you are running kde, gnome or else? Who is the Vendor of your GPU?

Please share nvidia bug report log file as soon as issue hit. We are trying repro by matching config you guys using. Also what desktop env you are running kde, gnome or else? Who is the Vendor of your GPU?

Thanks for this info. Who is the Vendor of your GPU? What desktop env you are running Unity, Gnome, KDE?

The vender is Gainward and the DE is just normal Unity. Again it’s stock Ubuntu 17.04 with nothing changed, apart from installing Nvidia drivers. The flickering begins at the login manager.

OK
Gnome 3.24.2.1
Gainward geforce gtx 760 2gb

Chassis: desktop
Operating System: Fedora 26 (Workstation Edition)
CPE OS Name: cpe:/o:fedoraproject:fedora:26
Kernel: Linux 4.12.5-300.fc26.x86_64
Architecture: x86-64

nvidia-bug-report.log.gz (225 KB)