Suspend corrupts window manager (?) after upgrade to 378.09

Yesterday I upgraded display drivers to 378.09 through Ubuntu additional drivers, restarted the computer and everything seemed OK. Today I woke my computer from S3 and got colourful garbled window edges and corrupt title bar. Second suspend & wake changed the look of the edges.

“unity --replace” fixes the issue, but it comes back after every time I suspend with varying severity. For example, in last test only passive window title bars and window control buttons are garbled, but it can make the window borders extremely wide (100px or so) with solid non-theme colors.

Never saw anything like this with 375.26.

Edit: Here is an example of what it can look like http://sarka.kapsi.fi/img/bug.png

I’m having the exact same issue. I’m running Ubuntu 16.04LTS with the 378.09 driver on my MSI GT62VR 6RD laptop with a GTX 1060 graphics card.

The unity trick works. Thanks, I didn’t know that, but it would be ideal if the laptop would resume without any graphical glitches.

Yes, this happens to me as well on both 16.04 and 16.10 on both 375.26 and 378.09 on MSI GS63VR 6RF with GTX 1060.
Also using Intel for powersaving using prime-select is very buggy. Computer doesn’t shutdown or restart. I had to force shutdown.
Also while I am not doing any GPU intensive work, my GPU fans kick in and the temps are around 55C.

I have exact same problem with 378.09 and Ubuntu 16.10.
375.26 works fine.

Hi All, Are you sure 375.26 don’t have this issue? Please attach nvidia bug report and photo showing this issue. Make sure to blacklist nouveau and vga=0

I dropped back to 375.26 and problem is gone. You can find a photo in my first post, however the corruption looks a bit different after every resume. Forgot to mention that I’m using Ubuntu 16.04LTS with GTX1070.

Here are the photoes : http://imgur.com/uDwThVr and http://imgur.com/RBcYTu2 with driver 378.09 and http://imgur.com/p4T5QsG is normal situation with 375.26

I should add that this happens after resume from suspend.

The nvidia bug report : http://hrh.name/nvidia-bug-report.log.gz

I’ve also blacklisted nouveau like this : GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash vga=0 rdblacklist=nouveau nouveau.modeset=0” in /etc/default/grub.

Thank you.

Same here. *** nvidia devs. FIX THE DRIVER ALREADY!

Ubuntu 16.04, GTX 980 TI.

On 375.26 added in grub;

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash vga=0” fix for me, not corrupt screen, on return the suspend mode.

FYI. we are tracking this issue under Bug 200279091 .

Yeah there is no problem with 375.26 as i mentioned. The problem is on 378.09.

I have 375.26 now and my grub has this line:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

No problems. As soon as I update to 378.09 I get corrupted window borders etc.

Yesterday got new 375.39 update. And today testing suspend. It is same problem with corrupted window borders etc. Version is 375.39 long-lived branch. Ubuntu 16.04 LTS. NVIDIA GTX 770

in 375.26 version has not corrupted window borders.

Hi lahtis, Can you please share photo/screenshot of corruption? Also nvidia bug report .

375.39 long-lived branch
nivia-bugreport-logs: https://mega.nz/#!M1ZlSaqY!YtrgcKRnZoNyuZbCs10fb4SjTMc3himKYbDZ-OSw4TU
screenshot: http://i64.tinypic.com/69giae.jpg

sended also email.

We are able to reproduce this issue and engineering team is investigating it.

Updated drivers same problem. logs find to adrress: https://mega.nz/#!d0IXWSCJ!iwXTJ7WLFWc15b9obu6mEfHq--NXde2OoTXuuVIqg04

We are still investigating this issue. Fix is not yet released. Mostly upcoming driver release will have this fix.

Please release this! I carry my laptop back and forth from my office every day, and having to do a full reboot every time I start up is extremely tedious, to say the least. I would think that this problem is sufficiently disruptive to merit its own release.

Agreed, this is very annoying, what is even more annoying is that it doesn’t have a workaround for the time being other than switching to Nouveau driver.