[Various/all Distros] Numerous Performance & Rendering Issues on 390.25

Hello, NVidia team!

After upgrading from 387.34 to 390.25, I am experiencing several performance and rendering issues. These were encountered in the Opera browser:

In addition:

  • I can hear my hard drive working incessantly

None of these issues occur when using version 387.34.

Notes:

  • I briefly tried Chrome. web.whatsapp.com was very laggy on 390.25, while being snappy and responsive on 387.34.
  • However, picture upload/paste worked in Chrome on 390.25.

PC Specs:

  • GeForce GTX 970
  • 32 GB RAM
  • Intel i7 4790K
  • System partition: on SSD
  • /home partition: on conventional 7200 RPM HDD
  • Dualboot system with Win 10 and Linux Mint

This is how far I investigated the issues before rolling back to 387.

Since I cannot find a button to attach files here, I have dropboxed the report log:
https://www.dropbox.com/s/2pc4j9vu6m9e8sx/nvidia-bug-report.log.gz?dl=0

When using Chrome, enter chrome://gpu/ to see the state of Chrome hw accel. Might work in Opera, too but I’m not shure about that.

Hey generix, thanks for the suggestion! Yes, it works the same way in both browsers. I forgot to mention that I double-checked that as well during the few hours I was on version 390. Acceleration is enabled for everything except:

CheckerImaging: Disabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Software only. Hardware acceleration disabled

This is pretty much the same I’ve had in the past few years. I wonder if the problem is unrelated to any browser settings? I did have a lot of uninterrupted hard drive activity while I was on 390, though I can’t say for sure whether it was also rattling while I didn’t have a browser open.

I’ve been back on 387.34 since yesterday and my system runs smoothly.

Browser hw accel seems to be normal, then. You could use iotop to see what is thrashing the hdd. Maybe check if the shader cache in ~/.nv gets abnormal high usage.

I’m glad someone else has seen this too!

I as well have a GTX 970 with 390.25 but I’m not seeing the excessive hard drive usage. I’m also on Mint 18.3.

I’m using chromium and will sometimes get black rendered rectangles in web pages and it’s very laggy when I scroll. I’m going to drop back to 390.12.

Same problem on my MSI with a GTX970 after the upgrade to 390.12 driers. Linux ming 18.3, chrome is flaky, slow, and choppy. I’ve turned off hardware acceleration and seem to have things working as expected again.

Just to find similarities besides you’re all using GTX 970 on Mint, are all of you also using xorg server 1.18.4?

Thanks for the further suggestions! I will try to find some time today or tomorrow to go back to 390.25 and have a look at iotop and the ~/.nv folder, and to investigate the hard disk thrashing a bit more. It’s a busy end of the week here, but when I have more data, I will post back here.

In my case, yes, X.Org X Server 1.18.4 (which you probably knew from the log).

I’m not very familiar with Xorg or the distinctions between these processes, so I’ll only say that these are the processes that mint runs on my GPU:

| 0 2046 G /usr/lib/xorg/Xorg 692MiB |
| 0 2626 G cinnamon 213MiB |

X -version
or
head -n5 /var/log/Xorg.0.log

Yeah, 1.18.4 (11804000) for my xorg server.

Hi there,

I’m very glad to see there are other people who have the same problem. I have a GTX 1060, using Mint 18.3 as well, X version 1.18.4 (using an i7 7820, 32 Gb Ram, SSD).

Earlier this week I also tried Ubuntu 17.10 and XUbuntu 17.10, and they exhibit the same problem. 387.34 works perfectly, on the other hand.

I derped and made a duplicate thread: https://devtalk.nvidia.com/default/topic/1029642/linux/google-chrome-and-firefox-have-bad-hw-acceleration-performance-on-390-25/

Long story short, it’s not just Mint that’s affected, but something in how Chrome interacts with the system/driver makes the problem manifest. The same issue doesn’t seem to manifest in NWJS, which is based on Chromium.

For what it’s worth, I did not notice the hard drive activity mentioned in the first post.

Same situation for me on Arch Linux with xorg 1.19.6, nvidia 390.25 and kernel 4.15.1. However not only chrome, but also my chromium browser is affected.

In addition to this there is also a new bug which breaks vsync as seen on vsynctester.com this makes all video including Netflix unwatchable due to stutter (60 hz instead of correct 59.95 as before). Let me know if you experience stutter (I will be starting a new thread). Hardware is in signature.

I too am seeing the same issues on Antergos (Arch Linux) with nvidia 390.25 and kernel 4.15.1. I actually googled “390.25 linux performance” and found this thread.

Definitely some bad performance regressions in this driver.

PC Specs:
GeForce GTX 1060
32 GB RAM
Intel i7 8700K

Same problem here.

980ti
Threadripper 1950x
Arch Linux
nvidia 390.25-4
kernel 4.15

Performance in Chromium (especially video rendering) is significantly worse than before the update and all my games have significantly worse performance by more than 50%. Skyrim via wine was running at 50-60fps, now I’m seeing 15-20. I did mess around with my wine config trying to diagnose the issue so it could be part of it too.

It could be a kernel issue. The meltdown/spectre updates were supposed to hinder performance but this doesn’t seem CPU related to me.

The stutter, in games at least, occurs when new resources are loaded. For example, while playing Starcraft II via wine, when a new unit was rendered or a new texture was loaded it caused stutter. For example, the game would run smoothly-ish (worse than earlier drivers) but stutter when I clicked on a new unit type for the first time. It loads the unit portrait and a few other things. This happened once per unit, once all the units had been clicked on once, the stutter mostly stopped.

I’m using Fedora 27 with KDE and 390.25 as well. Same problem - except even the desktop is slow to respond.

This is on a Ryzen 1700x @ 3.9GHz and a 1060.

390.12 did not have this issue.

I wonder if this has something to do with the new memory allocation workaround found in 390 series.
My system with 750Ti seems fortunately unaffected.

At first I thought it’s only me and my setup as I couldn’t locate any similar reports to this one. Now I’m glad I found out that it affects more than just me.

As a few already mentioned - 387 doesn’t have such issues. I’m on Ubuntu 16.04 and 4.13 kernel.