Stuttering in OpenGL applications (Mint 17.1, Cinnamon Desktop)

All,

I’ve noticed serious stuttering while using OpenGL applications (games in Steam, glxgears, etc). I’ve got a GTX 970 and currently running driver version 351.21. My Samsung monitor has a reported refresh rate of 60 Hz.

With Sync to VBlank and Allow Flipping off, glxgears reports ~13411.539 FPS. There is visible stuttering in the gear movement.

With Sync to VBlank and Allow Flipping on, glxgears reports ~55.785 FPS. The stutter seems even worse than with these settings off.

Xrandr reports:

Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1600x1200      60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9

So… If Sync to VBlank is on shouldn’t glxgears and other programs use the 60 Hz refresh rate? Why does it fluctuate be twee 53 FPS and 56 FPS (and is this the reason for the big stutter)?

Not sure if it’s relavant but my Xorg.0.log is flooded with:

[  1097.080] (--) NVIDIA(GPU-0): 
[  1097.110] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): connected
[  1097.110] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): Internal TMDS
[  1097.110] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): 330.0 MHz maximum p
ixel clock

Thoughts?

Thanks!

Neil

nvidia-bug-report.log.gz (182 KB)

I used to have some pretty bad stutter and performance issues under linux mint that magically fixed themselves when i switched distro somehow.

Maybe related to if your using cinnamon

https://devtalk.nvidia.com/default/topic/729908/linux/-gt-334-21-redrawing-problems-in-gnome-3-10-3-12-gtx-580/

I installed Mate and gave that a go but it produced the same result. Next I may need to try a clean install of Mate only. Still, strange it’s about 5 FPS off from the monitor refresh.

Ok, so I did a clean install of Mint 17.2 RC with the Mate desktop. Out of the box with the nouveau drivers playback is smooth. Once I switch over to the NVIDIA-Linux-x86_64-352.21 driver I again get the ~55 FPS with stuttering.

Maybe this evening I’ll get time to try and capture a bug report or revert back several driver versions and see if it works.

Another quick edit… I just reverted back to NVIDIA-Linux-x86_64-343.22 and it fixed the problem! I’m now at ~60 FSP which matches my monitor resolution. There still seems to be a slight stutter but it’s nothing compared to before.

I’ll try to file a bug report tonight.

Anecdotally I’m not sure that Mint’s desktop stack is particularly well written, it’s like a fork of a fork of Ubuntu’s already somewhat flaky compiz/lightdm setup. I wouldn’t be surprised if they tweaked something that causes issues for Nvidia drivers.

Ok, added a bug report on the original post.

I’ve not played around with different driver versions to figure out which caused the issue but at this point I know 343.22 works.

I’ve narrowed down the window of when the behavior started.

It happened between the 343.36 and the 346.35 release. 343.36 was the last “good” driver before the stuttering and FPS / refresh rate difference. I’ve not yet tried the 346.22 beta between those two drivers.

I hope this helps! Looks like for now I’m sticking with 343.36.

Neil

Can you change AA settings in game when stuttering happens and see if it’s gone ? Maybe it’s similar to my issue.

No, changing the AA settings does not make a difference.

I’m on 343.36 now and it’s much better. I can still detect a very slight stutter but it’s nothing compare do the 346 (and later) series drivers.

Hi,

i noticed a very strange stuttering in WarThunder (native linux version) using the 351.21 drivers on Opensue Tumbleweed using GNome3 and KDe5.

Switching back to thr latest 346 fixed it for me (still not perfect). In 352.21 the game was unusable.

Cu,
Christian

Woo hoo! I’m not the only one!

Sometimes diagnosing a problem in linux is like asking people if they hear the voices in your head.

I forgot to add my system details:

GTX 970
Intel Core i 5 3570k
16GB RAM
OpensuseTumbleweed
KDe 5 and Gnome 3

LostDog, On what are the games you are observing Stuttering ? Is any specific settings are done in game or steam? Is it possible to share video recording that shows the issue?

Sandip,

Sorry, I’ve been out of town and missed this reply. Any game at all (or any program like glxgears) will cause this. Later today I’ll switch to the latest drivers and get a recording.

Thanks!

Ok, here are some videos. The first two are from Transistor.

As the video moves up, the downward movement is extremely jerky:
https://goo.gl/photos/DEbyvvGVh3gpQDjG9

In this one you can see the stuttering as your character is running around:
https://goo.gl/photos/R4cwn3xJ4eiHQZoV6

This is the glxgears application. Notice in nvidia-settings the monitor refresh rate is 60. Also notice the reported fps in the console. When using the nouveau drivers playback is extremely smooth not even a slight stutter. With any NVIDIA-XXX.XX driver there is a small amount of stutter but it is REALLY bad with drivers above 343.36.

https://goo.gl/photos/dS1wmaNBqCmEirDq7

@LostDog: Do you use an xorg configuration file?
If it’s the case, could you please share it’s content, I think I’ve had the same problem not too long ago.

I’m seeing EXACTLY the same stuttering in Warthunder like it is shown in that video:

…In this one you can see the stuttering as your character is running around:
https://goo.gl/photos/R4cwn3xJ4eiHQZoV6

This is default as generated by the nvidia setup.

cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 352.21  (buildmeister@swio-display-x64-rhel04-13)  Tue Jun  9 22:44:03 PDT 2015


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection