Problems with multiple OpenGL applications running simultaneously with 375.20 on a GTX970

Starting with the 375.20 driver release, if I try to run multiple OpenGL applications at the same time on my GTX970, often launching another OpenGL application will result in the application either crashing or failing to work properly (textures not loading, extreme slowness). I can reproduce this quite easily by running multiple copies of “glxgears” simultaneously. If I launch 6-10 instances, the most-recently-launched instance will display a black window only. I can also reproduce by launching a few (4ish) Google Chrome windows and then attempting to launch a game (Xonotic) (which crashes entirely) or lock the screen in KDE (which results in a very sluggish and essentially non-functional lock screen.

This issue does seem to be at least somewhat limited to certain generations of GPU, however, because on my laptop with an NVS5400m, I can run at least 20 glxgears instances simultaneously and the KDE screen lock still works normally even with 10 Chrome windows open.

I have attached the nvidia-bug-report.log.gz taken from the system with the GTX970 while reproducing the problem. If I can provide any other data, please let me know.
nvidia-bug-report.log.gz (323 KB)

I think I have the same problem with GTX980 on Kubuntu 16.10. Running Deus Ex: MD or Dying Light on 375.20 results in extremely low frame rate (< 1 fps) or hangs:

  • Deus Ex: MD main menu is very low fps. The game hangs while loading if I try running the benchmark.
  • Dying Light in main menu seems fine but after loading the game the frame rate drops below 1 fps and stays that low even if I quit to the main menu again. Sometimes the main menu is low fps from the very start as well.

Both games run fine on 370.28 driver on the same system.

I attached my nvidia-bug-report.log.gz.
nvidia-bug-report.log.gz (284 KB)


I have the same issue with 375.20 on Archlinux using Plasma/KDE5. CPU i7-6700K, EVGA GTX970, kernel Linux arch 4.8.8-2-ARCH.

DeusEx DM cannot reach the main menu, and Shadow of Mordor drops to 1fps.

I wanted to notify that 375.10 driver works fine, so regression happened between 375.10 and 375.20.

I’ve tried to reproduce the issue the same way the previous posters did. Launched 11 Successful GLXgears Windows and the 12th came black. Meanwhile I also opened a game (Unreal Gold) while the GLXgears were running and I could hear sound but picture was black, have repeated the procedure twice and got exactly same results.

System Specs:

Intel Core i5-4590
Linux Mint 17.3 with Mate Desktop
EVGA Geforce GTX 960 (2GB)
8GB System Ram

Ahh, this explains why my KDE lockscreen stopped working…
I can confirm, same exact issues.
Running a GTX 980, 375.20 driver, on ArchLinux.

My bug report:

I am on Manjaro Distro,using Plasma and have a GTX980 , worst drivers ever for me

These drivers really destroy KDE Environment, Plasma was half functioning. right panel bar not showing .
Plasma Freezing if you click anything from system settings.
And the worst of all is that I couldn’t even launch a game to play! :(

I just had exactly the same problem on Arch with Plasma and a GTX970 and fixed it by regenerating my initramfs (mkinitcpio -p linux)

Forget it. the bug just returned after about 3h >_>

Using Gentoo, with Plasma 5.8.3 on ASUS G751JT.210 ROG laptop with a Geforce GTX 970M.

Just updated to Nvidia drivers 375.20 - so I could test out xorg-server 1.19.0.
Seeing similar issues to those reported.

Originally vpdau would not work - when I was running Chrome. Plasmashell would randomly lock up.
I tried regenerating my initramfs - again - this appeared to help some of the issues.

Bioshock Infinite is so slow - I can’t even get past the menu screen!
I can’t run more than 2 glxgears instances - subsequent ones render as black windows.

So still all kinds of erratic behaviours - that were not present in the 375.10 version of the Nivida drivers.

nvidia-bug-report.log.gz (298 KB)

Thanks all for reporting this issue. We are tracking this issue under bug 200255253

With KDE (kwin 5.8.3) and this driver a little test program I wrote that uses OpenGL hangs when calling the function SDL_GL_SwapWindow(win); (happens only when there is another OpenGL program running)

Program received signal SIGINT, Interrupt.
0x00007ffff243e35c in ?? () from /usr/lib/
(gdb) bt
#0 0x00007ffff243e35c in ?? () from /usr/lib/
#1 0x00007ffff243ed0f in ?? () from /usr/lib/
#2 0x00007ffff242f9e1 in ?? () from /usr/lib/
#3 0x00007ffff243d1be in ?? () from /usr/lib/
#4 0x00007ffff230b84c in ?? () from /usr/lib/
#5 0x00007ffff24034ab in ?? () from /usr/lib/
#6 0x00007ffff23e30fe in ?? () from /usr/lib/
#7 0x00007ffff23e320a in ?? () from /usr/lib/
#8 0x00007ffff336dd96 in ?? () from /usr/lib/
#9 0x0000000000400cc9 in main (argc=1, argv=0x7fffffffe038) at /home/tesx/dev/opengl-test01/main.c:73

Here’s the code…

It’s still reproduceable that vdpau breaks, for all media applications, if I start an instance of chrome/chromium… Starting to use vdpau, then launching a (hardware accelerated) web browser is fine though!

I’m having the same problem with my GTX 650 Ti. I have Chrome open and trying to open The Witcher 2 through Steam and it just hangs on the intro video and usually goes to a black window as reported by others here.

I am running 375.20 on Fedora 25 and all of my games are performing terribly: Life Is Strange, Deus Ex, CounterStrike GO, etc.

I am encountering the same problems. I can’t even access certain areas of the system settings while firefox is running due to this openGL issues. Also, multiple instances of glxgears will fail.

Running: Arch / linux-lts / nvidia-lts 375.20 / kde / kwin / sddm / x11 GTX 970 (Also happens on the current arch kernel, it is not limited to the lts kernel)

I will post a stacktrace as soon as I get home.
systemsettings5-20161122-005038.kcrash.txt (6.88 KB)

These drivers 375.20 should have been removed so far from Nvidia website since it causes all these kind of problems.

Btw how can I check that bug 200255253 as a user? I cant find any info…Any solution yet on this or any new driver?


This is internal bug id for tracking this issue. We are working on priority to fix this ASAP.

The regression was identified, so the next 375.XX release will carry a fix. In the meantime, there is no workaround that we can offer, so please downgrade the driver to 375.10.

I’m also seeing weird things with v375.20 (the last one, minutes ago, when the Second Life viewer closed down on me without a reason: no crash, it just closed down, something that I never saw happening before).

There’s also the Xid 69 issue I reported yesterday, and still the (extremely annoying) problems with the driver never returning you properly to the Linux console whenever X is closed/killed.

There’s also the installation issue with v375: ‘Cannot create symlink /usr/lib32/ (File exists)’

This 375 branch (375.10, 375.20) is a total wreckage ! In over a decade of running NVIDIA drivers under Linux, I never witnessed such a fiasco !

I’m returning to 370.28, which is the last stable driver version for me.

Please, consider making v370 a long lived branch, instead of v375, because I foresee a lot of problems with the latter, while the former worked flawlessly (at least for me).

Unfortunately I made a full install recently and the only way for me to downgrade is manual install that would make things worse. Thanks Nvidia! I’m glad that AMD is finally getting it together, and now I wish I had waited a few months to buy my new PC.


can you give us any ETA for the new release? Unfortunately, my OS is close to useless as I really can´t run things simultaneously.

Best Regards