Periodic stutter/hiccup/skip using OpenGL / Debian Linux on multiple systems

I encounter periodic micro-stutter every 1-2 seconds in all OpenGL applications i try.
So i was debugging trying to find the source of what visually seemed like small frameskips every 1-2 seconds, digging deep in the network-sync code. After a lot of digging it started to get maddening - frametimes are smooth, positions are smooth, framerate is high, load is low… So i grabbed a minimal opengl example and it showed the same stutter, tried glxgears and for good measure a unigine-demo, all the same weird stutter - no matter how fast and smooth the programs actually run and render.
Checked with nvidia-gfx-debugger, smooth frametimes, no apparent problems.

Tried:
VSync on/off in driver and code
ForceComposition on/off
Driver update
Disable/swap monitors and cables
Run in pure X without anything else
Toggling compositing
Resolutions/refreshrates
Slamming head on keyboard
Fullscreen/Windowed (More stutter in windowed, still obvious in fullscreen)
With and without xorg.conf
With and without option for tripplebuffering
Any button and slider in nvidia-settings
Disabling/Enabling threaded optimizations and singlethreaded per always-on-profile
taskset-ing,chrt-ing,renice-ing,ionice-ing the processes
Starring at plots, logs, temperatures …
Forcing CPU/GPU frequencies to max
Lots of combinations of the above and stuff i have already forgotten.

Now this happens on two rather different systems, both running recent debian and 4.9.something kernels.
One using a Quadro K2000 the other a GTX580. One with ssd one without, different cpus, different everything.
Only thing common is the OS and the fact the cpus are by intel and the gpus by nvidia.

One thing i noticed is that when running with 2 screens (exact same models and settings) and stretching the opengl-app over both, the stutter does not happen on both screens simultaneously.

Apart from the stutter the systems both run smooth, have no visual tearing. A simple test just moving a textured quad around the screen at a constant speed is smooth as butter apart from this maddening stutter.

I don’t use this systems to game (much), and don’t care about that. But when debugging this is sooo annoying - was that a bug-stutter or a mad-stutter? is it my code or is it that weird thing? makes rewriting my rendersystem so frustrating =/

As i hinted, i am not able to plot or log any hard information that would correlate with the stutter, it’s only visual. No plot i could think of has peaks matching it, not sysload,memory,frametime,context-switches,pages-in/out,voltages,temps…

I would really, really appreciate some help. Searching the web all ends up with “duh, try vsync” and the like.
The only thing left i can think of at the moment would be to try a different distro, i would however really like to continue using debian.

report for the k2000 system: http://dunkelraum.net/share/nvidia-bug-report.log.gz
report for the gtx580 system: http://dunkelraum.net/share/gtx580_nvidia-bug-report.log.gz

Note: this did not start recently, it’s just that i now started rewriting a rendersystem at which point it became infuriating.

Update: tried ubuntu 16.04.2 with 384.59 drivers, same issues

I’ve been looking into this internally but I haven’t been able to reproduce this issue. Could you upload a video of your reproduction. (Preferably on a bare X-server. Optimally with something like glxgears or some other easily available application.)

Is this issue worse on the K2000 or the GTX 580?

You say this isn’t a recent issue. How long has it been happening?

Tracked with issue# 1980769 .