black screen at desktop login [GTX 750 Ti] [390.25]

Hi everyone !
Using Fedora 27 x64 with xfce, kernel 4.14.16-300.fc27.x86_64, I’m running into some issues since the nvidia 390.12 drivers. With these, I could only see a black screen instead of my desktop (but it was clearly “running”), and there was nothing I could do (I reverted back to nvidia 384).
With the nvidia 390.25, things got a little better : my desktop still starts on a black screen, but quickly switching from tty2 to tty1 (ctrl+alt+f2 then ctrl+alt+f1) gives me back my desktop. Now, I’m noticing that every tty on my machine can’t display anything (guess what… black screen - -’). So I’m guessing that my settings on this machine are now wrong since the changes introduced by the newest drivers, but I have no idea what to look for… I could use your expert help !

Anyway, thank you for your help in advance

nvidia-bug-report.log.gz (138 KB)

Confirm this. Gentoo x86_64, Kernel 4.15.2, nvidia 390.25, GeForce 1050.

At least, I’m feeling a bit less lonely with this issue now.
There’s something else I noticed I should tell : whether I’m on a tty or in ‘my black screen desktop’, disconnecting and reconnecting the HDMI will give me back the console or the desktop. Same for you alpir ?

After login (Slim) i got black screen with toolbar and empty tray, no sense on mouse click. After switch to any tty and back i got fully loaded XFCE desktop. Last line in Xorg.0.log after tty is :
[ 40.867] (II) NVIDIA(0): Setting mode “nvidia-auto-select+0+0{ForceCompositionPipeline=On}”

This behavior started with 390.12 and 390.25 nvidia drivers, with kernel 4.14.14, 4.14.15, 4.15.2.

After comment out in xorg.conf line with
Option “metamodes” “nvidia-auto-select +0+0 {ForceCompositionPipeline=On}”
XFCE loaded successfully.

My temporary solution:

  1. comment out line with
    Option “metamodes” “nvidia-auto-select +0+0 {ForceCompositionPipeline=On}”
    in xorg.conf
  2. Create autostart in XFCE with command
    nvidia-settings --assign CurrentMetaMode=“nvidia-auto-select +0+0 { ForceCompositionPipeline = On }”

With 390.25 i got another bug while on tty and with launched Virtualbox: Xorg logs are filled with multiple instances of the following error: “Suspend swap group failed” and “Resume swap group failed.”
https://devtalk.nvidia.com/default/topic/1029683/linux/suspend-swap-group-failed-resume-swap-group-failed-nvidia-390-25/

Nice temporary workaround !
As for me, I got the same weird ‘suspend/resume swap group failed’ messages too, without virtualbox.

Also installing xfce-base/xfwm4-4.13.0-r1 from unstable tree (Gentoo) did resolve problem without commenting in xorg.conf.

There seems to be a related issue on OpenSuse 42.3 with the 390.25 drivers on kde/plasma (with the latest kernel from OS, and a GTX750-Ti card) the log-in screen is invisible ! All that is visible is a cursor, but the screen is there and typing the password brings me to the normal desktop ! I suppose I can live with this until something updates and fixes it, but it is annoying !

OpenSuse leap 42.3 with kernel 4.4.114-42-default problems started after I updated nvidia drivers to 390.25. Kwin started to crash and restart. Hight CPU and GPU load.

To make things worse they removed the fully working 384.111 drivers from the 42.3 update page, so there is no “clean and easy” way to go back, unless the ones for 42.2, which are still there, work. Yast2 only shows the latest nVidia entry, so even if the old ones were there they would not be automatically installable.

Just a final note for now, I changed the repository to 42.2’s and “upgraded” to 384.111 with Yast2 and all is well. I’m going to leave the repository set there until the non-functional 390.25 on 42.3 is replaced and I’ve looked for complaints !

I can confirm this bug appears for me in Arch - kernel 4.15/nvidia 390.25. When booting with “Force Composition Pipeline” enabled in xorg, I am met with a black screen and mouse cursor. Disabling “Force Composition Pipeline” in xorg, as previously mentioned, does allow me to boot into XFCE with LighDM.

I haven’t tested other DE’s, but there was mention of the same issue in the arch forums using cinnamon DE with above kernel and driver.

I’m seeing this with a GTX 650 Ti on openSUSE 42.3 on a dual monitor setup.

After logging into the blank sddm screen, the desktop is jerky and slow and I see repeated logging of the following (by using journalctrl):

Feb 15 16:22:11 kosmos1 kernel: NVRM: GPU at PCI:0000:01:00: GPU-4bd67998-117e-33ea-3d7a-62387850f887
Feb 15 16:22:11 kosmos1 kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception on GPC 0: 2D KIND Violation. Coordinates: (0x30, 0x0)
Feb 15 16:22:11 kosmos1 kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception: ESR 0x500420=0x80000040 0x500434=0x30 0x500438=0x2a 0x50043c=0x10017
Feb 15 16:22:11 kosmos1 kernel: NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception on GPC 1: 2D KIND Violation. Coordinates: (0x10, 0x0)

In respect to sddm, I’m seeing the following logged, but I’m not sure it’s relevant:

Feb 15 16:22:09 kosmos1 sddm-greeter[3827]: High-DPI autoscaling Enabled

Feb 15 16:22:10 kosmos1 sddm-greeter[3827]: QObject: Cannot create children for a parent that is in a different thread.
(Parent is SDDM::GreeterApp(0x7ffd36f28430), parent’s thread is QThread(0x140a010), current thread is QThread(0x17d1a80)
Feb 15 16:22:10 kosmos1 sddm-greeter[3827]: QObject: Cannot create children for a parent that is in a different thread.
(Parent is SDDM::GreeterApp(0x7ffd36f28430), parent’s thread is QThread(0x140a010), current thread is QThread(0x17d1a80)

Switching to the 384.111 driver for openSUSE 42.2 steps around the issue for now.

Am glad I found this post - As gusr19 noted, I’m also running openSUSE Leap 42.3 with a GTS 450 card and the 390.25 drivers resulted in booting up to an “invisible log-in screen” - Essentially a black screen with an arrow cursor. After playing around for a few hours trying to track down the issue and get things working properly, none of which worked, I just followed his lead and installed the 42.2 version of the drivers. With the exception of Yast complaining about a dependency issue prior to installation, all seems to be working fine. Hopefully will see a fix for 42.3 soon - Have not had a problem with the nVidia drivers or repositories for quite a few years now.

For opensuse 42.3 you can check NVIDIA repository. I see that date for drivers has changed to today but right now I don’t see any feedback that this new build works as expected.

NVIDIA-Linux-x86_64-387.34 drivers should work, too, I think (since I reverted to these ones once I hit the issue).
I tried solution #6 as suggested earlier by alpir. There’s no xfwm4-4.13.0-r1 package in Fedora rawhide, so I installed the xfce 4.13 dev (from a copr repo, which include xfwm4-4.13) with no luck : issue still here (plus xfce 4.13 messed up my desktop in the meantime). So far, I’m stuck with the workaround.

Thanks to serkbugs for the heads-up on the newly posted openSUSE Leap 42.3 drivers - Was gonna check for that next week. 390.25-10.1 was built this morning (15th) and posted this afternoon. Installed them to replace the 42.2 drivers and, so far, they work. No more “invisible log-in screen”, and no problems. Headed on a long weekend road trip tomorrow, so probably won’t get the really put them through the wringer until after Monday; but right now VERY happy the new update has apparently fixed the previous problems.

Yes, it’s working for me too :-)

I’ve installed 390.25-10.1 and both the openSUSE Leap 42.3 login screen and desktop are now functioning normally. I don’t see anything of concern in the output from journalctr or any of the text logs.

I would like to express my thanks to all involved with resolving this issue - especially to those who contributed suggestions for work-a-rounds, and those that actually fixed the driver.

A bit more info of what was going on would have been nice, but it’s even better to have it fixed, I did note the following in the driver RPM:

+Package: 2018-02-16 14:32:50 x11-video-nvidiaG04-390.25-10.1

  • /etc/dracut.conf.d/50-nvidia-$flavor.conf
    • generate chmod, mknod, cat, echo, chown and nvidia kernel
      modules nvidia, nvidia-drm, nvidia-modeset, nvidia-uvm into
      initrd (bsc#1080742)
  • /usr/lib/tmpfiles.d/nvidia-logind-acl-trick.conf
    • add additional line for nvidia-modeset device (bsc#1080742)
  • /etc/modprobe.d/5*-nvidia-default.conf
    • changed owner/permissions of /dev/nvidia-modeset to root:video
      and 660; seems to be sufficient and even needed for gdm on TW
      now (boo#1080742)
  • kmp-post.sh
    • groups are now dymamic; set group ID accordingly in
      /etc/modprobe.d/50-nvidia-default.conf during installation
      (boo#1080742)

I’m still seeing the same problem with v390.25.11 and Force Full Composition Pipeline enabled on boot. Can you guys please confirm if it’s enabled or not in your /etc/X11/xorg.conf. Or if it’s checked off in nvidia-settings.

I can confirm the issue if either ‘ForceCompositionPipeline’ or ‘Force Full Composition Pipeline’ is enabled in xorg.conf with Fedora. I don’t know for OpenSuse.