EVO Push buffer channel allocation failed is back as UseDPLib false no more supported with 325.15

I had to use the trick UseDPLib “false” in my xorg.conf to get the external monitor to work when connected on DisplayPort of my dockstation. Seems this option has been removed but the bug causing the external screen to blank and shut down is still there…
nvidia-bug-report.log.gz (49.2 KB)

[ 54.745] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[ 58.752] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[ 58.755] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
[ 58.757] (EE)
Fatal server error:
[ 58.757] (EE) AddScreen/ScreenInit failed for driver 0
[ 58.757] (EE)
[ 58.757] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 58.757] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 58.757] (EE)
[ 58.769] (EE) Server terminated with error (1). Closing log file.

That error used to be corrected by the 'UseDPLib false ’ trick or by letting the laptop lid open wheile strating X. I now have to resort to second trick which is really annoying especially because if you forget, your laptop is dead (power button needed as VGA input is routed to external monotor that suspends itself…)

I can confirm this - UseDPLib false was necessary to use nvidia on retina macbook pros. Without it, the x server always starts with a blank screen (and the above error).

es92, Please provide nvidia bug report and reproduction steps.

Please provide reproduction steps in detail.

What do you want? If I boot my dell Latitude E6410 laptop docked with a monitor connected on the doc via dipslayport and the lid closed, the external monitor enter power save mode and I have no way to bring it back. Only press the power button. This is not a new bug but an old one. Google “EVO Push buffer channel allocation failed”. You simply have disabled the workaround without having fixed the bug. This happens on many dell and mac machines.

Here’s the bug report:

reproduction steps for retina macbook pro:

  1. be on linux (I’m on 3.10.7)
  2. install nvidia module 325.15
  3. attempt to boot x11 on a computer that has in the past required the x11 option UseDPLib “off”

For retina mbps, it appears this error only happens in efi mode. In bios mode the driver works fine without UseDPLib

To add more info, on my side I’m not using efi on my dell

I’m experiencing the exact same problem. Running Gentoo Linux on a Dell Precision M4600 notebook. When upgrading to the 3.10.1 kernel, I had to upgrade to the 325.15 nvidia driver as well.

Apparently this driver ignores the UseDPLib “False” option, connecting any other monitor will fail to start X with the Evo Push Buffer allocation failure. This includes booting the laptop closed while in a dock with two external monitors, as well as booting it closed with a Display Port connected flat panel.

I’ve reverted back to my 3.8 kernel, tried the 325.15 nvidia driver there, same problem. Reverted back to 319.32 driver, and all works again.

Basically there’s no way for me to upgrade to a 3.10 kernel now, because the NVIDIA drivers version 319 fail to compile against a 3.10 kernel. This is a computer I use for work every day. Not being able to attach an external monitor makes it kind of unworkable. I’m hoping NVIDIA will quickly resolve this issue, for now it looks like I’m stuck with a 3.8 kernel and the 319.x NVIDIA driver.

The laptop is equipped with the following card:

NVIDIA GPU Quadro 2000M (GF106GL) at PCI:1:0:0 (GPU-0)
[ 27.840] (–) NVIDIA(0): Memory: 2097152 kBytes
[ 27.840] (–) NVIDIA(0): VideoBIOS: 70.06.36.00.03
[ 27.840] (II) NVIDIA(0): Detected PCI Express Link width: 16X

The familiar X.org error when using the new driver, or using the old driver without the UseDPLib “False” option:
[ 21.986] (EE) NVIDIA(GPU-0): Failed to tear down EVO channel
[ 26.056] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[ 26.059] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer

Internally filed Bug 1359500 to track this issue.

We are able to reproduce this issue and investigating …

Just a quick update: I believe I’ve identified the problem and it should be fixed in the first 331.* beta release.

Hi, thanks for tracking this.

I have a Macbook Pro Retina and tried installing the 331.13 drivers with the 3.11.5 kernel (patched to fix the num_physpages/get_num_physpages() issue). The EVO issue appears to still exist on my system and I have the following lines in my Xorg.1.log:

[ 35.915] (EE) NVIDIA(GPU-0): Failed to tear down EVO channel
[ 39.925] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[ 39.928] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer

I’m attaching the logs from the broken setup along with my previous working setup that uses nvidia-drivers 319.49 and Linux 3.9.
x-working.log (17.9 KB)

Running 13.04 Ubuntu on Dell Inspiron 7720(the one with the 3d display).

Installed xorg-edgers ppa
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

sudo apt-get install nvidia-current
This will install 304.108

This works when the following line is in the xorg.conf
Option “UseDPLib” “false”

sudo apt-get install nvidia-331
This will install 331.13 and remove 304.108

I get the EVO push button error and X11 won’t start.

Additionally
sudo apt-get install nvidia-325
This will install 325.15

The same error.

jolting, can you please generate and attach an nvidia-bug-report.log.gz file after reproducing the problem with the 331.13 or 331.17 driver?

I can confirm the bug is fixed for me with 331.13 => thanks.

I’m an Arch Linux user (mainly because of their quick upgrades), booting via EFI. I’ve been stuck on kernel 3.9.8 and nvidia 319.32 because of this issue for months. I just tried nvidia 331.17 (package from the Arch User Repository) with kernel 3.11.6, and this issue is still ongoing.

I’ll see if I can generate a bug report log next weekend, but this is my work laptop (mid-2012 MacBook Pro Retina 10,1) and I start a week-long on-call rotation tomorrow, so I have to stick with the stable configuration I currently have for the time being.

If there’s anything at all that I can do to aid Nvidia in solving this issue, I’m more than happy to help. I’m a linux engineer, and work with a few dozen engineers and developers who have been opting for less-capable Dell or Lenovo laptops because of the horrible reputation for Nvidia graphics on the MacBooks.

I’m running Ubuntu 13.10/64-bit (kernel 3.11.0-12-generic) on an iMac 13,1, booting with EFI (rEFInd http://www.rodsbooks.com/refind/), and have exactly the same issue, with various versions of the driver. The latest I tried is rev. 331.20, which gives the ‘usual’ errors

(EE) NVIDIA(GPU-0): Failed to tear down EVO channel
(EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
(EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
(EE) AddScreen/ScreenInit failed for driver 0
(EE) Server terminated with error (1). Closing log file.

Please tell me if I should post the full log, or any other information which might be helpful.

I would highly appreciate a working Nvidia driver on Macs, as I have some issues with the nouveau driver, too - I see horizontal “sparks” at the right border of the screen, which is annoying if the background is dark.

Thanks in advance, Albrecht.

i’m still getting this error with 331.20… let me know what information you need to fix the problem.