Blank Screen with 319.12 on Optimus Laptop

Hello everyone.

I set up the above mentioned driver according to

http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html

The configuration is correct, xrandr reports both providers, setting the provider output source works and X goes up as expected using kdm. However, the screen remains blank, though the backlight remains active. There are no errors.

ASUS X53S
Ubuntu 13.04 completely up to date
Kernels 3.8.0-16 and 3.9.0-rc6
Intel Core i5-2410M
NVIDIA GT540M

Any clues? TIA!

I’m getting the same blank, backlit screen. X will start without complaining, run programs invisibly and glxinfo will report Nvidia, but there’s nothing on the LVDS or HDMI.

Unity and other DEs will try to load, but report framebuffer errors.

Providers for Nvidia and modesetting (or Intel, I’ve tested both) report properly.

Clevo W150HRM
Core i7 2630QM
Nvidia GT 555M
Ubuntu 13.04
Linux 3.9-rc6
xorg-edgers and xrandr 1.4

Perhaps not the same as what you both are attempting, but give Bumblebee a shot:
http://bumblebee-project.org/

And because I see you’re both on Ubuntu 13.04, probably with the affected xorg package, you’ll need this fix to get it working:
https://github.com/Bumblebee-Project/Bumblebee/issues/367#issuecomment-16094317

This is about using the new Optimus and RandR 1.4 support in 319.12, not Bumblebee.

Our BusIDs are properly set up.

Why would we return to Bumblebee when there’s the prospect of native support? O_o

Maybe it’s kernel issue. LLStarks, do you have proper support for the Intel GPU with 3.9RC6? In my case there seem to be issues at least with GLX.

Same trouble.

lsb_release -d

Description: NAME=Gentoo

uname -r

3.9.0-rc5

dmidecode -t system

dmidecode 2.11


Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
Product Name: 550P5C/550P7C
Version: P02AAA

lspci -k|grep NVIDIA

01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M / GTX 660M LE] (rev a1)
$ xrandr -v
xrandr program version 1.4.0
Server reports RandR version 1.4

also uncommented
Option “UseDisplayDevice” “none”

Why would it be a kernel issue? Sandybridge has been fully supported for over 2 years now.

Has anyone else tried using Intel instead modesetting?

I’m going to try both with VGA (HDMI has only mirrored the tty) later today.

No one attached nvidia-bug-report files?

I’ve sent the necessary logs to Aaron on IRC. You’re welcome to attach here.

I have the same problem, adding bug report file http://www.hot.ee/wingleader/nvidia-bug-report.log.gz

Blank screen with backlight and nothing more happening.

OS: OpenSuSE 12.3 x64
Xserver: 1.14
Xrand: 1.4
Kernel version: 3.8.6
CPU: Icore7 3-rd gen.
GPU: Geforce 630M GT

So what the problem could be?

You need 3.9 kernel

@LLStarks
Thats nice, but would you mind posting your logs here too, so everybody gets more information who is interested? You might want to read the forums sticky:“2) Please always include a copy of an nvidia-bug-report.log.gz file,…”
@stylertim
Since LLstarks bugreport is aaron-only, could you please load up yours? I am interested in a bugreport on a correctly configured Ubuntu machine.

[edit] Solved, didn’t follow directions.

I have the same blank display issue.
I can run programs… output of xrandr
Screen 0: minimum 8 x 8, current 640 x 480, maximum 16384 x 16384

Thinkpad T530
NVIDIA Corporation GF108M [NVS 5400M] (rev a1)

http://dl.dropbox.com/u/60600291/nvidia-bug-report.log.gz

/etc/X11/xorg.conf
-> http://nopaste.info/6551757669.html

/var/log/Xorg.0.log
-> http://nopaste.info/77d76019e8.html

linux-3.9-rc6
xf86-video-modesetting-0.7.0
xorg-server-1.14.0

Here’s my stuff
nvidia-bug-report.log.gz (91.5 KB)

Not sure how to edit posts.
I did not follow all of the directions.

~/.xinitrc
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Display works now.

[wut@sawako]0[~]%xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x2b3 cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x44 cap: 0x2, Sink Output crtcs: 3 outputs: 2 associated providers: 1 name:modesetting

xrandr also displays the outputs I would normally get with my Intel card.

[edit] Edit button appears when you mouse over the posts :P

Thinkpads are wired differently than most Optimus laptops

Hmm, if some of you succeded, then why it doesn’t work in my case? Buglog was attached before

I wrote, you need 3.9 kernel

Still no luck, giving up. Ubuntu, all sys requirements ok: blank screen.

For aaron ;) :
nvidia-bug-report logverboselevel6: http://paste.ubuntu.com/5708254/
few more infos: http://paste.ubuntu.com/5708256/

Can someone who has success (Gentoo/arch seems to work?) post his /var/log/Xorg.0.log please?
I’d like to compare, stumbled about this modesetting (EE) error, and some NVIDIA (WW) warnings …

TIA

http://nopaste.info/60a1848401.html

LFS system.