[319.17] Black screen + xrandr can't open display in Optimus

I have similar problem to topic Blank Screen with 319.12 on Optimus Laptop but not at all.

Distro is Arch x64 with testing repo (xrandr 1.4.0-1, xorg-server 1.14.1-1, kernel 3.9.2).
Driver installed from repo, tried from .run file too, but got errors with loading kernel module and no screen found.
Notebook is Dell XPS 15 L502x with Intel HD3000 and GF 540m (screen connected to Intel).
xorg.conf in attached log file created using instructions from http://us.download.nvidia.com/XFree86/Linux-x86/319.17/README/randr14.html and I don’t see any errors in Xorg.0.log but screen is black with backlight working. Tried to use intel driver instead of modesetting but nothing changes. Problem is that to fix it I should use xrandr commands

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

But every xrandr command with this xorg.conf gives error can’t open display (-q and -v too).

Log (why there is no button to attach file?):
http://pastebin.com/dbXfu0WY

Same problem, black screen on a backard bell for Geforce 310M and Linux Kali 1.01 32bit. Here is the log http://speedy.sh/bSgBM/nvidia-bug-report.log

Same issue can not provide the log Dell 17r 7720 ubuntu 13.04 kernel 3.9.1 Nvidia 650m + intel hd 4000

@s_grec
According to your logfile you use X.Org X Server 1.12.4 and Kernel 3.7. ?

@WWW123
No log, no fun.

s_grec, you shouldn’t even need the driver since your laptop seems to be a muxed Optimus with a physical or BIOS switch.

@pogopuschel
3.7-trunk-686-pae #1 SMP Debian 3.7.2-0+kali6 i686 GNU/Linux

X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0

this is info u required me

@LLStarks
Forgive my ignorance, but, do you mean that I have an Optimus multiplexed with a switch for graphic card?

Thank you for your advices, I 'd like only to activate graphic effects…

@sgrec if you want to use Optimus, you need to install kernel 3.9, xrandr 1.4 and xorg 1.4 - function that is used in new driver is available from that version.

So nobody can help me :/

@Agalin
You will get “can’t open display” when not using
DISPLAY=:0 xrandr

But anyway, you should put those xrandr commands in a file, eg .xsessionsrc
so they are run when logging in.

I put them into .xinitrc. But I’ll check if this file have +x. So where I should use DISPLAY=:0?

sudo DISPLAY=:0 xrandr --setprovideroutputsource modesetting NVIDIA-0

just

DISPLAY=:0 xrandr --setprovideroutputsource modesetting NVIDIA-0

or

xrandr --setprovideroutputsource modesetting NVIDIA-0 DISPLAY=:0

?

No, you do not need the DISPLAY=whatever prefix in .xinitrc…
Just put

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

in there. Btw, in Ubuntu .xinitrc does not work, thats why I suggested .xsessionrc instead, do not know how archlinux behaves. No need to set it executable or use a shebang …

So maybe it’s .xinitrc related - I had this code all the time (started with this). So I’ll log in Arch (now on Windows) and try manually insert code.

Edit. Nothing changed. Code copied to .xsessionrc, tried DISPLAY :0 - used code in shell (x autostarted so changed to empty terminal):

xrandr -d :0 --setprovideroutputsource modesetting NVIDIA-0 #tried from user and from root)

And error was “No protocol specified” on first line and standard “can’t open display” on second.
Tried to startx and on user it crashes, on root crashed after xrandr command (parameter -d :1).

@Agalin
No idea. Your X-Server version has the correct patches? There was a patch set from 1.4 to 14.1 from redhat which broke stuff and had to be fixed by another patch from Aaron, eventually you have to rebuild X-Server.

I don’t know. I’m using repo version and it’s Arch - so there is big chance that there is that wrong patch.

I got the same error with same error messages in xorg.log as Agalin.

@pogopuschel
I downgraded the x-server from 1.14.1-1 to 1.14.0-2 because i think you meant that with your previous post. But there was no success in removing the error by doing this.

Hi,

Kernel 3.10.17
OS Slackware 14.1 x86_64
nvidia-settings: version 331.20 Wed Oct 30 18:20:32 PDT 2013

Xorg /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard" 
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0" 
    Driver         "mouse"  
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"  
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown" 
    ModelName      "Unknown" 
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:01:00:0"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    Option         "UseDisplayDevice" "none"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Xinit /etc/X11/xinit/xinitrc

#!/bin/sh

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

[...etc...]    
startkde

Where’s the point? KDE starting correctly, I can clone display to the external HDMI monitor BUT i can not set anymore a large desktop on two screens :/ My external Monitor on HDMI has a black screen, and turn off.

Do you have any idea what’s wrong?

Thx a lot,

webster / Valheru

1 Like