Cannot start X from February 2016 - Nvidia Optimus

Hi,

From the beginning of February 2016 I cannot start X with my Nvidia Optimus, so I can only use Intel graphics.

Gentoo ~amd64 Linux & Nvidia 630M 1GB.

I use (and tested):
kernel: 4.5.0-r1 (4.4.6 - 4.5.0)
nvidia proprietary drivers: 364.12-r1 (346.96 - 361.28)
xorg-server: 1.18.2 (1.16.4 - 1.18.1)
intel drivers: 2.99.917_p20160324

To have working X, I use startx form text console and Xorg.0.log shows only 1 error:
http://pastebin.com/rSLBSkFf

(EE) modeset(G0): failed to set mode: No space left on device

^^ When I was searching Google, looks like this error was only in Gentoo. No idea what’s wrong.

I have such error on the screen after typing ‘startx’ from the console:

xrandr: Configure crtc 2 failed 
X Error of failed request: BadValue (integer parameter out of range for operation) 
Major Opcode of failed request: 139 (RANDR) 
Minor Opcode of failed request: 21 (RRSetCrtcConfig) 
Value in failed request: 0x0 
Serial number of failed request: 45 
Current serial number in output stream: 45 
xinit: connection to X server lost

Everything is as should be in Nvidia guide:
http://us.download.nvidia.com/XFree86/Linux-x86_64/361.28/README/randr14.html

Hi,

As there is no answer, I would like to ask if there is any linux website with professional support, where I could pay for the help?

Do you think this error is related to modesetting in kernel?
(EE) modeset(G0): failed to set mode: No space left on device

Hello have you figured out a solution yet?

Got it after 6 months. The solution for this problem, is to compile xorg-server (>17.4) with glamor flag enabled. I know is against Nvidia advise, but it works.

Tested with xorg-server 18.4 & Nvidia Driver 370.28
Hopefully xorg-server & nvidia developers will find the reason.

Here is full bug topic:
https://bugs.freedesktop.org/show_bug.cgi?id=94577