Blank Screen with 319.12 on Optimus Laptop

Thanks, skvitek. You seem to have added a modeline for the modesetting driver… can you please show your xorg.conf also?

Tia, pogo

Is everyone that has this working using Xorg 1.14.0? I get a blank screen on a Thinkpad T530 with Xorg 1.13.3.

I tested 1.13.3 and 1.14.0, blank screen.

I just upgraded to Xorg 1.14.0 from git and it is now working on my Thinkpad. It was not working with Xorg 1.13.3.

Have the same problem with blank screen with backlight and nothing more happening.
Additional info :
Archlinux (fully updated)
Linux 3.9.0-rc7
Xorg 1.14.0
xrandr 1.4

Asus N53Sv
Intel Core i3
NVIDIA GT540M

https://dl.dropboxusercontent.com/u/2675816/.xinitrc
https://dl.dropboxusercontent.com/u/2675816/nvidia-bug-report.log.gz
https://dl.dropboxusercontent.com/u/2675816/Xorg.0.log
https://dl.dropboxusercontent.com/u/2675816/xorg.conf

May you give me advice, what i must to do next?

Ok, I’ve got it running in Ubuntu 13.04.
Hints:
Use xrandr 1.4 eg from git, not that 1.35/1.4 Ubuntu version, otherwise you had to set the provider id as numbers, according to the
xrandr --listproviders
output.
Using .xinitrc did not work for me. had to create .xsessionrc instead of.

I run X-Server 1.14.0 fom PPA https://launchpad.net/~canonical-x/+archive/x-staging.
Caution: Atm you have to install libudev0 manually, since for some reason eg. xserver-xorg-core depends on it.
Also added whole xorgedgers PPA , Kernel Ubuntu Mainline 3.9rc6

Runs pretty nice, no clipping here with openarena so far …

Thanks. I was wondering why the staging PPA wasn’t working before.

Rebooting into Linux now to confirm.

Sorry, forgot to mention: using Intel instead of modesetting driver.

I used modesetting

Are you getting tearing like I am? Aaron mentioned that it was an X limitation.

Btw, VDPAU works

http://media.cdn.ubuntu-de.org/forum/attachments/18/15/5537712-Screenshot_from_2013-04-21_212321.png

Hello, I also have this problem (blank screen, backlight is yet functioning and adjustable with the Fn keys).

I followed the hints of pogopuschel, but unfortunately the problem still persist.

Here is a quick summary what I did on my Ubuntu 13.04 installation (beta 2, 64-bit):

  • Installed mainline 3.9 kernel (rc8) and rebooted
  • Added PPA: x-staging and xorg-edgers, and performed an apt-get upgrade and rebooted
  • Grabbed the xrandr source via GIT, build it (had to apt-get install xorg-macros, xutils-dev and libxrandr-dev) then performed: make && make install
    To make sure there are no conflicts with the Ubuntu version of xrandr, I renamed /usr/bin/xrandr to /usr/bin/xrandr.old and created a symlink /usr/bin/xrandr -> /usr/local/bin/xrandr
  • Installed the packages: nvidia-319 nvidia-settings-319
  • Created the xorg.conf, using the instructions of the readme’s driver. Later I also combinated it with a generated xorg.conf with tool nvidia-xconfig
  • Disabled the lightdm service to prevent automaticly launch the X server at booting
  • Created the file .xinitrc in my home directory (I also created file ~/.xsessionrc with the same contents, but no luck)
  • After all of above, I launch ‘startx’ under my username when Ubuntu is booted.

Am I missing something? Maybe somebody can give me some advise.
nvidia-bug-report.log.gz (51 KB)
.xinitrc.txt (99 Bytes)
xorg.conf.txt (1.73 KB)

output of xrandr --listproviders.txt (230 Bytes)

Does your xrandr Symlink work?
xrandr -v has to show 1.4 twice, not 1.35 and server 1.4 as the Ubuntu version shows.

Is your .xsessionrc executable? (chmod +x)

Use the Intel driver. Your xorg.conf shows “modesetting”.
Here is a copy of my xorg.conf and .xsessionrc:
http://paste.ubuntu.com/5598753/

Good luck!

Thanks for your reaction.

  • I checked the symlink, it’s working. When I execute ‘xrandr -v -d :0’ on a tty (while the X server with blank screen is running), I get the following output:

xrandr program version 1.4.0
Server reports RandR version 1.4

  • No, the file .xsessionrc was not executable. So I made it executable. To be sure, I also made the file .xinitrc executable. So results are as follows:

$ ls -la /home/christian/.x*
-rwxr-xr-x 1 christian christian 239 Apr 24 16:55 .xinitrc
-rwxr-xr-x 1 christian christian 239 Apr 24 16:56 .xsessionrc

But no luck, still blank screen.
I also copied the text of your section of xorg.conf and .xsessionrc as new files on my system (BusID is good), but still blank screen.

Do you launch the X server manually, or leave it to lightdm?

Have you rebootet? For some reason -I do not understand ;)- restarting X gave me no success after creating/editing the files, had to reboot.

I use autologin. Try it and delete the line in your .xsessionrc:
exec gnome-session

Yes, I have rebooted several times.
I removed the line ‘exec gnome-session’, enabled lightdm en configured autologin for it and rebooted.
Still no luck. :(

But thanks for your help.

A funny thing is that I see my screen from another computer with a VNC viewer, when desktop sharing (vino) in gnome is enabled. And nvidia-settings also detect my videocard (Geforce GT555M) and glxgears also sees it, but the physical LVDS screen remains black.

Ok, installing the stuff on a friend’s machine gives me blank screen again. It turned out that something weird happened to the new packages xserver-xorg-common xserver-xorg-core 1.14.1 from X staging PPA.

Using the old versions 1.14.0 and installing libudev0 works again. Nearly, Unity does not want to load the sidebar.
Glad I didn’t upgrade my machine :)

https://launchpad.net/~canonical-x/+archive/x-staging/+build/4349898
https://launchpad.net/ubuntu/raring/amd64/libudev0/175-0ubuntu19

Update:

Posted a dirty Howto to get Optimus working on Ubuntu 13.04:

http://paste.ubuntu.com/5601226/
UPDATE! This guide is outdated. A maybe-again-working-version is here:
http://paste.ubuntu.com/5606194/

DO NOT USE THIS ON YOUR MAIN SYSTEM. ONLY FOR THOSE WHO CANNOT WAIT!!
Since xserver 14.1.1 from Canonical X-staging ppa again does not work (blank screen) we downgrade to their old 14.1.0 version (which worked.) This results in broken dependencies, eg given installing ia32libs (you need for steam) will whipe the whole desktop. Try installing ia-32libs before testing this, but maybe this ugly howto will not work then. ;)

Hi there,
Just want to confirm that the instructions provided by pogopuschel worked for me

@Christian-NL Did you use the intel driver instead of modesetting as pogopuschel recommended ? (I got it working right after that change) Also, you have to update .xsessionrc as well and replace the actual “modesetting” by “intel”

On my side here is my configuration :

  • Asus UX51VZ (HDMI output wired to nvidia)
  • Ubuntu 13.04
  • GDM/Gnome (had some issues with Unity before going through the update process - menus/bars not showing)
  • Installed mainline kernel 3.9RC8
  • Added xorg-edgers ppa
  • Installed 319.12 drivers with the original NVIDIA script. (if you ask why, because I couldn’t figure out the correct name for the 319.12 driver in xorg-edgers, thx Christian)
  • Compiled xrandr 1.4 (same dependencies as Christian) only with make (no install), then put xrandr in my home dir and linked to it in .xsessionrc
  • Added x-staging ppa
  • Replaced modesetting by intel from original NVIDIA configuration proposed here : http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html

P.S. : I didn’t have to manually install libudev0.

The other thing that I want to figure out is how to re-enable GLX for Intel when using only the Laptop with no HDMI external output. Seems like the NVIDIA GLX drivers gets loaded instead. Looks like other people have already figure how to fix it:
http://askubuntu.com/questions/220271/no-glx-on-intel-card-with-multiseat-with-additional-nvidia-card
http://www.linuxadvocates.com/2013/03/making-nvidia-and-intel-play-nice.html

Cheers and thanks again pogopuschel for the howto!

kochouloo
http://ux51vz.blogspot.ca

@pogopuschel: Wow! I removed the existing installation and installed the official Ubuntu 13.04 version (released today) and followed exactly step by step your ‘dirty guide’ and it’s working now!
@kochouloo: Thanks for your help. Yes, I had the “Intel” driver specified in .xsessionrc and in Xorg.conf

I think the gold tip is somewhere after the part to create folder ‘xstuff’. I didn’t know you had to manually install xserver-xorg-core… and xserver-common…
Or maybe it was the command ‘apt-get -f install’ that did it.

pogo, any benefits to using Intel over Modesetting? Doesn’t it use more power even though you should be plugged in anyway?