334.21 Repainting issue GeForce 9400M

I’ve been pretty closely following the releases, and 334.21 is about where the issue began. Multiple on-screen-dialogs and my web browser will not visually update on click events like they should, and instead require me to move the window to trigger a repaint.

I’ll try to downgrade to see if I can find a working state in a previous driver and post here.
nvidia-bug-report.log.gz (124 KB)

I have the same redraw issue, on a GT650M, using 334.21 and running Linux 3.13.6 (Arch x64).
Before my upgrade to 3.13 there was no problem, but I may have updated the Nvidia driver at the same time as my kernel, so I do not know which of the two was the culprit.
The packages are not in my cache but I can probably get hold of older versions, to test around if necessary.
nvidia-bug-report.log.gz (187 KB)

Can you share photo or video for issue ?

I PMed you a video as requested.

I’ll also mention here that I am a Compiz user, which may or may not be interesting information.

TB,

I received video you provided. Plz provide below information :

  • Is thie issue repro if you disable desktop effects OR composite (nvidia-xconfig --no-composite) ?

Section “Extensions”
Option “Composite” “Disable”
EndSection

  • Make sure nouveau driver disabled :

add kernel parameter and reboot : vga=0 rdblacklist=nouveau nouveau.modeset=0
and

~# cat /etc/modprobe.d/disable-nouveau.conf
blacklist nouveau
options nouveau modeset=0

  • What desktop environment you are running - kde, gnome ?
  • What display manager you are running - gdm , kdm , lightdm ?
  • What window manager you are running - compiz, kwin, mutter, metacity ?
  • Did you tested with any old and latest drivers ftp://download.nvidia.com/XFree86/Linux-x86_64/ ?

I’ve had this repaint issue on anything > 319.49. Hasn’t gone away yet.

DE = Gnome-3.6
DM = gdm
WM = mutter
Version 319.49 works perfectly. Anything greater and I get the repaint issue.

I have disabled compositing in my xorg.conf file as suggested and the issue disappears.

So it seems it is a compositing issue.

My first post. How do I upload the bug report? Nevermind, got it.

This happens on both an older GT430 and a brand new MSI GTX 750.
nvidia-bug-report.log.gz (88.6 KB)

Tracking this issue under 1485912

Hi Sandip,

My nouveau driver is disabled by the ArchLinux packages:

[tom] [~]% cat /usr/lib/modprobe.d/nvidia-ck.conf blacklist nouveau [tom] [~]% cat /usr/lib/modprobe.d/nvidia.conf
blacklist nouveau

I’m using no DE to speak of. I’m running X more or less sessionless.
I’m using no display manager. I start X from command line.
I’m using Compiz as a window manager, and emerald as decorator.
I’m kind of forced by my WM to use compositing for X to even start at all.

When I switch to Metacity (2.34) instead of Compiz (without disabling compositing in X), I can not reproduce the problem. Even on KWin (4.11.7) with effects enabled, which do use compositing as far as I’m aware, I have not seen the issue.

I currently do not have time to try out different versions, but when I do, I’ll post results here. My suspicions are that for me, the problem occurred in the same versions as for overkll.

Compiz may very well have the same bug mutter had, or the compiz user could be seeing some entirely different bug with the same symptoms.

It would probably be worth try updating gnome packages to the latest versions to see if it fixes the issue. I think the relevant bug is here:

https://bugzilla.gnome.org/show_bug.cgi?id=724788

We tried with config (Ubuntu 14.04 64bit + NV334.21 driver + GTX 750 card + Gnome-3.12+Mutter-3.12)

Getting repro with Gnome-3.10 and below versions as well but After updating to Gnome-3.12 issue is no longer got exist. So this is not nvidia issue.

Gnome-3.13 (and Cinnamon) still has redraw issues here.

https://bugzilla.gnome.org/show_bug.cgi?id=728464

https://devtalk.nvidia.com/default/topic/729908/linux/-gt-334-21-redrawing-problems-in-gnome-3-10-3-12-gtx-580/1/

I have this same repainting issue, but on Slackware64 14.1 + Openbox + Compton + GTX460. If I disable compton, no more issue.
The last good driver for me is 331.89.

GNOME devs have a patch for this but can’t merge it at the time, as stated in the thread linked by leigh123linux.

They are said to be working on it but we don’t know if 343.13 beta drivers fix this, and we NEVER had any official statement from nVidia, which makes me wonder if I made the good choice when I considered buying a GeForce for my new computer.

I am very disappointed, as a simple reply from them would have been enough. Also I don’t know if there’s a way to contact them apart from these forums.

Not sure if I am experiencing the same issue as described. On occasion a window/frame starts to flicker between two states. I don’t know how to reproduce this though.

I tried updating from 334.21 to 340.32 binary drivers through the “additional drivers”, the ones with “(open source)”, which did not fix the issue.

OS - Ubuntu 14.04 (Unity)
Video card - NVIDIA GeForce 9600GT
Graphics driver - NVIDIA binary 334.21 and 340.32 (open source)

I’m not certain if this is the same problem as I am seeing, I’ve posted a small video that shows how it looks on my screen:

This happens on my Lenovo Thinkpad W520 with the NVidia GF106GLM [Quadro 2000M] card.

I’ve had this problem on Ubuntu 12.04 and 14.04 with all drivers above 3.31 if memory serves me right.

In the video it seems to offset parts of the screen just slightly, but sometimes I will see content that should be offscreen, like old contents from the terminals scrollback buffer.

I randomly get this kind of corruption in all applications.

Is this the same as other people in this thread is seeing?

I remember having the same behavior in my Guake terminal, when I reported the redrawing issue here:
https://devtalk.nvidia.com/default/topic/729908/linux/-gt-334-21-redrawing-problems-in-gnome-3-10-3-12-gtx-580/1/

It was a problem in clutter, which was fixed quickly. Just rebuilding clutter with the provided patch solved the problem.

What version of clutter does 14.04 ship?

There is someone else reporting issues with Ubuntu Unity.
https://lists.launchpad.net/compiz/msg50829.html

He’s referencing a different issue I reported after the initial flickering problem was solved. The current redraw problem can be fixed, by simply setting the card into performance mode. The problem also seems to be fixed in mutter and will be part of Gnome 3.14.
I suspect your problem is related to the first issue. You could try setting the card to “Prefer Maximum Performance” and see if it changes anything anyway.

We are working on priority for this issue. There are some related bugs also that we need to be fixed. We will keep your posted. Internally we are tracking this issue : 1485912

Hi Users, Please test with mutter version 3.17.90 or higher and report whether you are still seeing issues? We believe packages for this version of mutter are available for Fedora Core 23 now. Other bleeding-edge distros may have picked them up as well.