H265 4k rtp streaming: latency problem

I want to stream 4k video over cable with low latency.
So, I try next pipeline on Jetson TX2:

gst-launch-1.0 v4l2src device=/dev/video0 ! 'video/x-raw,format=(string)I420' ! nvvidconv ! 'video/x-raw(memory:NVMM),format=(string)I420,width=3840,height=2160' ! omxh265enc bitrate=10000000 preset-level=0 control-rate=2 ! rtph265pay ! udpsink host= port=30021


gst-launch-1.0 udpsrc address= port=30021 ! "application/x-rtp,encoding-name=(string)H265" ! rtpjitterbuffer ! rtph265depay ! avdec_h265 ! glimagesink sync=false

And I see that stream have a big latency ~2-3sec

But if I use H264 instead of H265 with similar pipeline, stream works fine.

gst-launch-1.0 v4l2src device=/dev/video0 ! 'video/x-raw,format=(string)I420' ! nvvidconv ! 'video/x-raw(memory:NVMM),format=(string)I420,width=3840,height=2160' ! omxh264enc bitrate=10000000 preset-level=0 control-rate=2 insert-sps-pps=true ! rtph264pay ! udpsink host= port=30021


gst-launch-1.0 udpsrc address= port=30021 ! "application/x-rtp,encoding-name=(string)H264" ! rtpjitterbuffer ! rtph264depay ! avdec_h264 ! glimagesink sync=false

I run “nvpmodel -m 0” and “jetson_clocks.sh” before streaming.
/dev/video0 returns 640x480 picture which I resize to 4k via nvvidconv (just for testing purpose).

How I can fix this problem?

Hi smarttowel0,
Why don’t you use HW decoder at client?
Does it also happen in 1080p30? i.e. is it resolution related?

Client doesn’t have HW decoder.
In 1080p H265 latency significantly lower than on 2160p, but H264 stream still work faster.
Maybe this problem related to some I/O operations? If I remove rtpjitterbuffer element from client pipeline, H264 stream works fine, but in H265 I see broken frames with low latency(!) video.

Please try with AU delimiter enabled and smaller iframeinterval

omxh265enc bitrate=10000000 preset-level=0 control-rate=2 insert-aud=true iframeinterval=15

Nothing changed

do you have two developer kits to try omxh265dec?

Hm, I tried to stream video from Jetson TX2 to Jetson TX1 and it’s works.
I don’t guessed that performance of my Core i7 not enough for 4k H265 decoding.