Having problem with installation of cuda on debian(Kali Linux)

I’m having issues with installation of cuda on my system, trying to install it using the apt package manager was giving the error below error so i tried searching for a solution for it and found a bit similar issue so I tried following the answer given at nvidia forum link but it didn’t help.

xserver-xorg-video-nvidia : Depends: xserver-xorg-core (< 2:1.20.99) but 2:21.1.4-2 is to be installed
$ uname -a
Linux kali 5.18.0-kali7-amd64 #1 SMP PREEMPT_DYNAMIC Debian 5.18.16-1kali1 (2022-08-31) x86_64 GNU/Linux
$ sudo sh cuda_11.8.0_520.61.05_linux.run                              
[sudo] password for secovfshanks: 
 Installation failed. See log at /var/log/cuda-installer.log for details.
$ cat /var/log/cuda-installer.log
[INFO]: Driver not installed.
[INFO]: Checking compiler version...
[INFO]: gcc location: /usr/bin/gcc

[INFO]: gcc version: gcc version 12.2.0 (Debian 12.2.0-3) 

[INFO]: Initializing menu
[INFO]: nvidia-fs.setKOVersion(2.13.5)
[INFO]: Setup complete
[INFO]: Components to install: 
[INFO]: Driver
[INFO]: 520.61.05
[INFO]: Executing NVIDIA-Linux-x86_64-520.61.05.run --ui=none --no-questions --accept-license --disable-nouveau --no-cc-version-check --install-libglvnd  2>&1
[INFO]: Finished with code: 256
[ERROR]: Install of driver component failed. Consult the driver log at /var/log/nvidia-installer.log for more details.
[ERROR]: Install of 520.61.05 failed, quitting