headless initial configuration: looking for password

Hi,

I’m trying to do a headless initial configuration as is promised with the last SD image released. I’m looking for the password of the nvidia account which should be available on the Nano

My experiences so far:

The Nano is connected via usb to my linux system. I see a network connection like expected, the Nano is 192.168.55.1. However, no port is open on the Nano so ssh nvidia@192.168.55.1 is not possible.

The serial port is working on /dev/ttyACM0 and by using picocom like suggested on the usb drive documents of the Nano I can get a login prompt. I can’t find a working username/password combination however.

Who can help me?

Best regards,
Luc

Hi,

This is what I did. It is what the instructions say but if you have already read the very similar instructions for booting with Keyboard and mouse attached you might go off the rails a bit like I did.

  1. Make sure that you are using the correct boot image (the 7.1 GB dlinano image and not the jetson-nano image linked to elsewhere). The link for this is in the headless directions.

  2. Power the nano up (green light on board should light up). Count to 30. Plug in the usb cable and open up a window on the machine from your linux box at 192.168.55.1:8888 and log in to the Jupyter server for the first time using ‘dlinano’ as the password.

Hope that helps. The tutorial is a breeze and you’ll be up and classifying in no time.

Good Luck!

Chris

Once you flash SD card image, you need to accept terms & conditions, set your clock, timezone etc. at your first boot. (You need monitor and keyboard for this step). Then you will set up Username and Password for Jetson Nano. You can use that password for login through device mode.

If you have already completed above steps, can you

$ping 192.168.55.1

and check command line output if the packets are lost.

Please let me know.

Hi Chris,

This line of the JetPacks 4.2.1 Higlights did me beleive the normal SD image was able to do headless initial configuration:

Developer kits support initial configuration from another computer connected via the same USB port used for flashing. This is an alternative to setup with display, keyboard, and mouse attached to developer kit.

Apart from this line I was not able to find any instructions for headless initial configuration.

I try to find the dlinano image. I have once downloaded an older version while doing a course but did not yet find a direct link to the dlinano image.
Luc

Here’s an article on headless initial configuration on the Jetson Nano:

You will need to have a freshly flashed SD card running L4T 32.2+
Also, you will need to connect the Nano to your Linux, Macintosh or Windows host using a USB cable plugged into the Micro USB connector on the Nano. Make sure that the cable is data capable, a USB phone charger cable may not work. You will need to power your Jetson using the 5V 4A power jack, don’t forget the jumper on J48!

After powering on the Jetson, it takes ~ 30-45 seconds to boot with a default image. You should then be able to use a serial terminal application (such as screen on an Ubuntu or Macintosh, or puTTY on a Windows machine) and connect to the Jetson.

On a Linux machine, the Nano will present itself as /dev/ttyACM* (typically /dev/ttyACM0). On a Macintosh it is /dev/tty.usbmodem*. On Windows it is a COM port. The speed of the serial connection should be set as 115200. Connect to the Jetson (you may have to hit the ESC key a couple of times) and go through the configuration. The configuration is covered in the official NVIDIA L4T documentation: https://bit.ly/2ZmXJS1

There are several network paths you can select (Ethernet cable, wireless, USB and so on).

Once you have configured the Jetson, the Jetson will reboot and you will be able to SSH into it. You may find it useful after rebooting to serial app back into it to figure out what IP address is assigned to the Jetson Nano. You will be able to log into the account through the serial debugging port that you set up in the preceding steps.

I think I’m having the same problem as the OP in that once I try to connect through screen I am asked for a username and password. I’ve followed the guide provided above by @Kangalow. Even with a fresh flash on first boot, the Jetson seems to behave as if it’s already been through a setup if that makes any sense at all.

I am having the same problem. When I login through screen (/dev/tty) it is asking me for a password. How can I resolve it? I followed all the steps from the headless setup tutorial on Jetson Hacks.

What image did you flash? There should be no username or password. Normally the first (non system) user is created by you on first boot.

@mdegans I flashed the Jetson Nano SD Card Image r12.3.1 using Balena Etcher: https://developer.nvidia.com/jetson-nano-sd-card-image-r3231 . It gives me the following prompt when I run “screen /dev/tty.modem* 115200”:

Ubuntu 18.04.3 LTS localhost.localdomain ttyGS0

localhost login:

Is it possible that someone set a username and password previously? Even if it was the case, don’t the username and password get reset automatically when you flash a new image?

Also, I rebooted the device several times before (disconnected and connected the device to the power supply). On Jetson Hacks I found the following: “One of the setup issues that I have encountered is that if you try to exit/restart the configuration process, it may not be recoverable.” Will try to flash again and will report back, if I succeed.

@ben-n:

I’ve resolved my issue by going back one release to JP4.2.3. I tried the last 4 releases. Only the most recent (JP4.3) asks me for the the password. The others work as expected in the video posted by @kangalow. I hope this helps.

1 Like

Thanks. I’m flashing the linked image to sd card and will try to replicate. I’m going to try first with a usb>serial cable, flash again, and then with the microusb directly.

[   10.133904] Please complete system configuration setup on the serial port provided by Jetson's USB device mode .

looks like microusb is required

So it works for me. I get Nvidia’s license agreement, locale settings, user add screens, etc.

The device presented on my Ubuntu machine was “/dev/ttyACM0” If you are typing “/dev/tty.modem*” literally, it might be connecting to something else. You might “ls /dev/tty*” and see what options there are.

Do you mean that you tried the latest image that I linked or JP4.2.3? I will try the older release, as @poozwally suggested.

I think I am connecting to the right device (I inserted * to skip writing down the entire number). I am on Mac and “/dev/tty.modem*” only appears when I plug in the Nano. Will also try connecting with Linux.

I did try the latest release you linked to. Do you have a monitor connected to the nano? I do not. I am not certain, but if I recall correctly, the serial console will not present the first boot screen if a display is connected, and might show a login prompt instead. Can you post the full boot log shown at the serial console?

If there is only one /dev/tty.modem then you are probably connecting to the right device.

@mdegans I was able to setup the Nano after flashing the latest image again. I think the problem was due to multiple reboots during the setup, as Jetson Hacks mentioned. Thank you so much for your help everyone!

That will do it. It would be nice if the first boot process was more resilient to failure but it’s almost always just safer to reflash anyway. Glad you resolved the issue!

I’ve tried JP4.3 easily 10x fresh with a Linux computer connected by USB… I still get the login instead of the licence agreement.

I wasted a week trying this via a virtual machine Linux as a host. Then I found that if the host is not a Linux virtual machine then the setup script worked for me. For example with jetson TX2 as a host (Ubuntu 18.04 LTS) or with windows 10 as a host via putty app (as shown in the last part of the video of https://www.jetsonhacks.com/2019/08/21/jetson-nano-headless-setup/ )

After the setup script was run using Jetson TX2 or Win10 as a host, the connection via USB from a Linux virtual machine host works.

default password on mine was jetbot

Having the same issue with no luck. Using image 32.4.2, the latest available, to freshly flash the SD. Powering on Jetson Nano, waiting 30-45 seconds. Have tried on BOTH MacOS and Ubuntu with separate machines, using screen /dev/tty.usbmodem[assorted numbers] 115200 and screen /dev/ttyACM0 115200. Plugging in with a data capable microUSB cable.

On my Ubuntu machine, I immediately see “localhost login:”. On my Mac, I see the very first screen to accept the license, it crashes, then I’m back to “localhost login:”. I’ve re-flashed 4 times now. I have tried with ethernet connected and not. I have tried with two different microUSB cables.

Oddly enough, if I try ping 192.168.55.1, I do receive packets despite having gone through zero setup. Should I just buy a monitor and mouse at this point?