Heightfields in PVD

I’m using physx 3.2.2 and i’m trying to import a raw height map and put it in my scene. The problem i’m getting is that while the heightfield seems to load into physx just fine, and it shows up in physX visual debugger’s object list, it doesn’t seem to be rendering in the DirectX render window of PVD.

I also know it is there because a box falls and interacts with it.

Is there some flag I need to set to make it visible in pvd? I tried toggling show and hide in pvd’s options but nothing happened.

May I know which version of PVD you’re using? Have you tried it with the latest PVD? Could you post your PVD capture here? Thanks.

Its there, chances are you are below the terrain and cull mode will prevent those back facing polygons from being shown. I had the same issue for a while and I just started to rotate the view and would see sliver of geometry. I selected what I could see and use the camera to zoom to selection…and voila…my terrain was showing up.